Release-Notes für Version 1.57.0

Dieser Artikel enthält die Release-Notes für   logi.CAD 3 , Version 1.57.0Sie gelten auch für logi.CAD 3 , Version 0.57.0. Außerdem finden Sie in diesem Artikel auch Release-Notes, die nur für logi.CAD 3 , Version 0.57.0 gültig sind.

Die Release-Notes für die aktuelle Version finden Sie unter "Release-Notes für aktuelle Version".

Inhalt dieses Artikels:

Allgemeine Informationen

Zu →logi.RTS:

Wenn Sie  logi.CAD 3 , Version 1.57.0 oder logi.CAD 3 , Version 0.57.0verwenden, installieren und verwenden Sie die folgende Version von logi.RTS:

Das Installationspaket für logi.RTS ist im Lieferumfang von  logi.CAD 3  enthalten.

Zur Kompatibilität:
Falls Sie eine frühere Version von  logi.CAD 3  verwendet haben und die aktuelle Version verwenden wollen, lesen Sie unter "Sind meine Projekte aufwärts- und abwärtskompatibel?" nach, welche Punkte Sie beachten müssen.
Zum Raspberry Pi:

Lesen Sie in der Kurzanleitung Raspberry Pi in Betrieb nehmen nach, welche →Raspbian-Version für die Verwendung von  logi.cals  empfohlen wird.
Falls Sie eine neuere Version von →Raspbian einsetzen wollen, kommt u.U. ein Linux-Kernel ≥ Version 3.18 zum Einsatz. In diesem Fall können Probleme beim Hardwarezugriff auftreten (speziell auf Bus-Systeme, wie z.B. →I2C, SPI usw.). Im Zusammenhang mit →logi.RTS äußert sich die Problematik derart, dass z.B. Ein-/Ausgänge von →PiFace-Modulen trotz erfolgreicher Initialisierung nicht angesprochen werden können. Nähere Informationen zur Konfiguration von Linux-Systemen mit aktuellem Kernel finden Sie unter: http://www.forum-raspberrypi.de/Thread-tutorial-geraetetreiber-und-device-tree-dt

Neuigkeiten in  logi.CAD 3 , Version 1.57.0

IDNeuigkeiten
9021

Die Systembausteine System_close, System_open, System_read und System_write (siehe Bausteine zum Aufrufen von Systemfunktionen) können nun auch in Anwendungen für die integrierte SPS verwendet werden. Bisher wurden diese Bausteine nur für Raspberry Pi unterstützt.

Zusätzlich steht der neue Systembaustein System_delete zur Verfügung, mit dem eine Datei gelöscht werden kann. System_delete wird für Raspberry PI und die integrierte SPS unterstützt.
Siehe Neuer Baustein bzw. neue Bibliothek ist nicht in bestehenden Projekten verfügbar, falls Sie den Baustein in bestehenden Projekten verwenden wollen.

9135

Mit Hilfe der Sicht SPS Logging können Sie die Trace-Meldungen, die logi.RTS für die integrierte SPS protokolliert, nun direkt in logi.CAD 3 verfolgen.

9982

Sie können unbenutzte Variablen und nicht zugewiesene Ergebniswerte von Funktionen so in ST ermitteln: Kontextmenü des ST-Objekts, Befehl Validieren
Beachten Sie, dass die Validierung auf das aktuelle ST-Objekt eingeschränkt ist.

Neuigkeiten in  logi.CAD 3 , Version 0.57.0

keine

Behobene Probleme in  logi.CAD 3 , Version 1.57.0

Klicken Sie (mehrmals) auf eine Spaltenüberschrift, falls Sie den Tabellen-Inhalt anders sortieren wollen.

IDBehobenes Problem
9668

Der geänderte Name einer Konfiguration nach dem Laden der Anwendung verursacht einen inkonsistenten Zustand.
Behebung: Die beschriebene Änderung verursacht keinen inkonsistenten Zustand mehr.
Szenario für Problem: Falls Sie die Anwendung auf eine SPS laden (z.B. die integrierte SPS), danach den Namen der Konfiguration im SPS-Objekt (z.B. local.iecplc) ändern und das SPS-Objekt speichern, wird logi.CAD 3 in einen inkonsistenten Zustand versetzt. Dies äußert sich so:

  • Der Fingerprint in der Sicht SPS wird zuerst als geändert angeführt, dann wird jedoch wieder der ursprüngliche Fingerprint angezeigt.
  • Die Werte in der Sicht Variablenwerte werden nicht mehr aktualisiert.
  • Der konsistente Zustand kann durch ein erneutes Laden der Anwendung nicht wiederhergestellt werden.
9726

Ungültige Zeichen im Dateinamen werden beim Erstellen von ST-Objekten nicht verboten.
Behebung: Ungültige Zeichen im Dateinamen sind nun auch beim Erstellen von ST-Objekten verboten. Die ungültigen Zeichen werden gemeldet.
Szenario für Problem: Wenn Sie beim Erstellen eines ST-Objekts Umlaute oder Leerzeichen eingeben, wird das nicht verboten. Im Vergleich: Beim Erstellen eines Projekts und beim Umbenennen von ST-Objekten sind Umlaute oder Leerzeichen im Namen nicht erlaubt.

9907

Deutsche Online-Benutzerdokumentation wird für die englische Version geöffnet.
Behebung: Die englische Online-Benutzerdokumentation wird für die englische Version geöffnet.
Szenario für Problem: Falls Sie die englische Version von logi.CAD 3 geöffnet haben und dann die Online-Benutzerdokumentation starten (Menü Help, Befehl Help Contents), wird die deutsche Ausgabe der Benutzerdokumentation geöffnet.

9965

Die geöffnete Perspektive "Applikationstest" verursacht beim Starten von logi.CAD 3 eine Ausnahmesituation.
Behebung: Diese Ausnahmesituation tritt nicht mehr auf.
Szenario für Problem: Wenn die Perspektive Applikationstest beim Schließen von logi.CAD 3 geöffnet ist und logi.CAD 3 erneut gestartet wird, tritt eine Ausnahmesituation auf. In diesem Fall erscheint der Eintrag Unhandled event loop exception im Fehlerprotokoll.

9996

Die Inhaltshilfe bietet keine Einträge für die Initialisierung von Variablen mit einem Strukturdatentypen zur Auswahl.
Behebung: Für das folgende Szenario bietet die Inhaltshilfe nun Einträge, um die Variable mit dem Strukturdatentyp zu initialisieren.
Szenario für Problem: Wenn Sie die Inhaltshilfe verwenden, um eine Variable mit einem Strukturdatentyp zu initialisieren (siehe Beispiel), werden dort keine Einträge zur Auswahl angeboten.

Beispiel
PROGRAM Test
  VAR
    MyVar : MyStruct := ; (* To the right of ':=', the content assist does not list items for initializing 'MyVar'. *)
  END_VAR
END_PROGRAM
TYPE
  MyStruct : STRUCT
    intVar : INT;
    boolVar : BOOL;
  END_STRUCT;
END_TYPE

Behobene Probleme in logi.CAD 3 , Version 0.57.0

Klicken Sie (mehrmals) auf eine Spaltenüberschrift, falls Sie den Tabellen-Inhalt anders sortieren wollen.

IDBehobenes Problem
9542

Die Anwendung kann nicht geladen werden, falls Funktionsbausteine mit Parameter, die über einen allgemeinen Datentyp verfügen, im FBS-Editor verwendet werden.
Behebung: Die Anwendung kann für das folgende Szenario geladen werden.
Szenario für Problem: Falls Sie einen Funktionsbaustein, der über einen Parameter mit einem allgemeinen Datentyp verfügt, im FBS-Editor verwenden, kann die Anwendung nicht geladen werden. Diese Meldung erscheint: Die Anwendung für die SPS kann nicht erstellt werden.
Beispiel für solche Funktionsbausteine: Der FORCEMRK-Baustein hat Ein- und Ausgänge mit dem allgemeinen Datentyp ANY_ELEMENTARY.

9551

Ein Kommentarfeld im FBS-Editor kann nicht in die Zwischenablage kopiert und daraus eingefügt werden.
Behebung: Ein Kommentarfeld im FBS-Editor kann nun in die Zwischenablage kopiert und daraus eingefügt werden.
Szenario für Problem: Wenn Sie ein Kommentarfeld im FBS-Editor in die Zwischenablage kopieren (mit Hilfe der Tastenkombination Strg+C), ist es nicht möglich, es anschließend einzufügen (mit Hilfe der Tastenkombination Strg+V). Anschließend reagiert der FBS-Editor auf Tastenkombinationen nicht mehr, z.B. auf jene zum Ändern der FBS-Elemente.

9553

Eine Ausnahmebedingung wird beim Eintragen eines FBS-Programms als Programmtyp verursacht. Das FBS-Programm wird beim Laden der Anwendung nicht verwendet.
Behebung: Die genannte Ausnahmebedingung wird nicht mehr verursacht. Das FBS-Programm wird beim Laden der Anwendung verwendet.
Szenario für Problem: Falls Sie ein FBS-Objekt vom Typ FBS-Programm erstellen und dieses als Programmtyp in einem SPS-Objekt eintragen, wird dieses FBS-Objekt nicht für das Laden der Anwendung verwendet. Beim Speichern des geänderten SPS-Objekts tritt eine Ausnahmesituation in logi.CAD 3 auf und es erscheint der Eintrag com.logicals.iec.model.fbd.impl.FbdProgramTypeImpl cannot be cast to com.logicals.iec.model.pou.StObject im Fehlerprotokoll.
Zusatzinformation: Falls vor der Änderung bereits ein ST-Objekt als Programmtyp im SPS-Objekt eingetragen war, wird weiterhin dieses ST-Objekt für das Laden der Anwendung verwendet.

Bekannte Probleme in  logi.CAD 3 , Version 1.57.0

Klicken Sie (mehrmals) auf eine Spaltenüberschrift, falls Sie den Tabellen-Inhalt anders sortieren wollen.

ID

Bekanntes Problem

1795

Befehl "Öffnen mit", "Direkt angezeigter Editor" nicht erfolgreich
Szenario: Wenn Sie im Kontextmenü des Projektexplorers den Befehl Öffnen mit und Direkt angezeigter Editor wählen (z.B. für ein ST-Objekt), wird folgende Meldung angezeigt: Wiederherstellen des direkten Editors nicht möglich. Direktunterstützung fehlt
Abhilfe: Verwenden Sie den Befehl Öffnen mit und ST-Editor, um ST-Objekte und SPS-Objekte zu öffnen. Für andere Objekte, wie z.B. Textdateien, können Sie den Befehl Öffnen mit und Texteditor verwenden.

1844

"Umbenennen" und "Löschen" im Projektexplorer nach dem Starten von logi.CAD 3 möglich
Szenario: Nach dem Starten von logi.CAD 3  können Sie die Befehle Umbenennen bzw. Löschen aufrufen (aus dem Menü Datei bzw. Bearbeiten oder via Tastenkombination F2 bzw. Entf), obwohl diese keine sinnvolle Funktionalität haben.
Zusatzinformation: Dieses Problem tritt auch auf, falls Sie einen neuen Arbeitsbereich wählen oder den Arbeitsbereich wechseln und im Projektexplorer sind keine Projekte enthalten.
Abhilfe: Erstellen Sie ein Projekt und selektieren Sie zumindest eine Ressource darin, bevor Sie den entsprechenden Befehl aufrufen.

1920

Fehlermeldung beim Umbenennen von Projekten, die nicht im Arbeitsbereich liegen
Szenario: Wenn Sie ein Projekt außerhalb des Arbeitsbereichs erstellt haben und dieses anschließend umbenennen, werden interne Fehler angezeigt, dass die Datei .project (im Arbeitsbereich) für das Projekt nicht vorhanden ist. Das Umbenennen selbst hat jedoch funktioniert.
Zusatzinformation: Das Problem wird durch verlinkte Ordner verursacht, die Systembausteine enthalten. Beispiele für solche Ordner: IEC61131-3, Raspberry Pi IO. Diese verlinkten Ordner müssen jedoch im Projekt vorhanden sein, damit Sie Systembausteine in Ihrem ST-Code verwenden können.
Abhilfe (empfohlen, um die Meldung zu vermeiden):

  • Löschen Sie solche verlinkten Ordner im Projekt, das Sie umbenennen wollen.
  • Benennen Sie das Projekt um.
  • Erstellen Sie ein temporäres Projekt, das die verlinkten Ordner enthält.
  • Ziehen Sie die verlinkten Ordner aus dem temporären Projekt in das umbenannte Projekt.
  • Löschen Sie das temporäre Projekt.

Abhilfe (falls die Meldung bereits aufgetreten ist):

  • Im Explorer des Betriebssystems: Gehen Sie zum Ordner, der in der Meldung genannt wird und die Datei .project enthält. Löschen Sie diesen Ordner.
  • Löschen Sie die internen Fehler aus der Sicht Fehlerprotokoll.
2752

Kommentare werden beim Formatieren des Codes nicht zueinander ausgerichtet. Bei einem Kommentar am Anfang der Datei wird eine Leerzeile eingefügt.
Szenario: Falls Sie bereits vorhandenen ST-Code mit dem Befehl Formatieren (im Kontextmenü) bzw. der Tastenkombination Strg+Umschalt+F formatieren, werden Kommentare im ST-Code u.U. nicht zueinander ausgerichtet (siehe Beispiel).
Beispiel (vor dem Formatieren):

FUNCTION_BLOCK FUB_LEDCylon
    /*
     * The LEDs are shifted back and forth.
     */
END_FUNCTION_BLOCK

wird zu (nach dem Formatieren):

FUNCTION_BLOCK FUB_LEDCylon
/*
     * The LEDs are shifted back and forth.
     */
END_FUNCTION_BLOCK

Falls außerdem am Anfang der Datei ein Kommentar vorhanden ist, wird eine Leerzeile vor diesem Kommentar eingefügt. Dadurch beginnt die Datei mit einer Leerzeile.
Abhilfe: nicht vorhanden

2809

Verlinkte Ordner werden beim Exportieren eines Projekts in eine Archivdatei berücksichtigt.
Szenario: Falls Sie ein Projekt in eine Archivdatei exportieren, wird der Inhalt von verlinkten Ordner (z.B. IEC61131-3 mit den IEC-Bausteinen) ebenfalls exportiert. Falls Sie anschließend das Projekt aus der Archivdatei importieren, sind die zuvor verlinkten Ordner zu "eigentlichen" Ordnern im Projekt geworden. In Folge treten möglicherweise Probleme auf, wenn Sie die Objekte verwenden, die im (eigentlich verlinkten) Ordner liegen; z.B. wenn Sie die IEC-Bausteine im ST-Code erfassen.
Abhilfe: Beim Exportieren in eine Archivdatei klappen Sie das zu exportierende Projekt in der linken Liste des Dialogs auf, entfernen Sie die Markierung für die verlinkten Ordner und drücken Sie erst dann Fertigstellen, um den Export zu starten. Nach dem Importieren sind die verlinkten Ordner im Projekt automatisch vorhanden.

6049

Beim Ersetzen eines ST-Codes, der aus einer Vorlage stammt, erscheint u.U. ein Dialog mit einem Fehlersymbol, aber ohne Fehlertext.
Szenario für Problem: Wenn Sie einen ST-Code aufgrund einer Vorlage aus der Inhaltshilfe eingefügt haben und diesen durch den ST-Code einer neuen Vorlage ersetzen, erscheint u.U. ein Dialog mit einem Fehlersymbol, aber ohne Fehlertext. Nach dem Bestätigen des Dialogs werden nur die ersten Buchstaben vom ST-Code der neuen Vorlage eingefügt.
Beobachtet wurde dieses Problem, als ST-Code aufgrund der Vorlage for eingefügt wurde, dieser Code selektiert wurde und dann die Vorlage while in der Inhaltshilfe ausgewählt wurde. Nach dem Bestätigen des Dialogs wurde nur whi eingefügt.
Abhilfe: Löschen Sie zuerst den bereits eingefügten ST-Code. Fügen Sie erst dann die neue Vorlage aus der Inhaltshilfe ein.

7259

Eine Ausnahmesituation wird verursacht, wenn Sie ein Projekt schließen, das beim Starten von logi.CAD 3 mit mehreren Editoren bereits geöffnet ist.
Szenario für Problem: Wenn Sie ein Projekt schließen, das beim Starten von logi.CAD 3 geöffnet ist und gleichzeitig zumindest 2 Editoren geöffnet sind, wird das Projekt geschlossen, allerdings wird nur einer der Editoren geschlossen. Außerdem wird diese Meldung in einem Fenster und in der Sicht Fehlerprotokoll angezeigt: An internal error occurred during "Calculating highlighting". Es handelt sich dabei um eine Ausnahmesituation.
Abhilfe: Bestätigen Sie die Meldung im Fenster und schließen Sie die weiterhin geöffneten Editoren des Projekts (z.B. Menü Datei, Befehl Alle schließen). Löschen Sie das Fehlerprotokoll, falls Sie die Meldungen dort nicht mehr benötigen.

8898

"Mit Editor verlinken" im Projektexplorer hat manchmal keine Funktionalität.
Szenario für Problem: Bei gewählter Schaltfläche Mit Editor verlinken im Projektexplorer passiert manchmal nichts, wenn Sie den aktiven Editor wechseln. Tatsächlich sollte die Selektion im Projektexplorer mit dem aktiven Editor verlinkt werden.
Abhilfe: siehe Troubleshooting-Artikel Das Wechseln des aktiven Editors aktualisiert nicht die Selektion im Projektexplorer

9271

logi.RTS beendet die Ausführung der Anwendung auf einem Raspberry Pi, falls das PiFace mehrfach initialisiert wird.
Szenario für Problem: Falls die Anwendung das PiFace eines Raspberry Pis mehrfach initialisiert, beendet logi.RTS die Ausführung der Anwendung. In der Konsole von logi.RTS erscheint z.B. die Meldung wiringPiNewNode: Pin 80 overlaps with existing definition.
Abhilfe: Stellen Sie sicher, dass die Initialisierung mit Hilfe des RP_piFaceSetup-Bausteins nur einmal in Ihrer Anwendung erfolgt.

9535

Meldung kennzeichnet eine Vergleichsanweisung als fehlerhaft, obwohl dieser Vergleich funktionieren sollte.
Szenario für Problem: Falls Sie eine Vergleichsanweisung beim Assert-Baustein verwenden und dieser Vergleich bezieht sich auf einen Funktionsbaustein-Ausgang mit einem allgemeinen Datentyp (siehe Beispiel), dann wird die Vergleichsanweisung als fehlerhaft gekennzeichnet. Die Meldung Bei Vergleichsoperatoren muss der Datentyp übereinstimmen oder implizit konvertierbar sein wird dafür angezeigt. Tatsächlich sollte dieser Vergleich jedoch möglich sein und funktionieren.

Beispiel
PROGRAM Test
  VAR
    Var1 : SINT;
    iForceMrk : FORCEMRK; 
  END_VAR
  iForceMrk(Var1);
  Assert(iForceMrk.OUT = Var1);  (* The output 'OUT' of 'ForceMrk' is of the generic data type 'ANY_ELEMENTARY'. *)
END_PROGRAM

Abhilfe: Weisen Sie den Ausgang des Funktionsbausteins einer Hilfs-Variablen zu. Verwenden Sie diese Variable in der Vergleichsanweisung.

Beispiel
PROGRAM Test
  VAR
    Var1, helper : SINT;
    iForceMrk : FORCEMRK; 
  END_VAR
  iForceMrk(Var1);
  helper := iForceMrk.OUT;     (* Assign 'OUT' of 'ForceMrk' to an auxiliary variable. *)
  Assert(helper = Var1);       (* Use this auxiliary variable for the comparison. *)
END_PROGRAM
9713

Die Anwendung kann möglicherweise nicht geladen werden, falls Sie einen komplexen Ausdruck beim GET_BYTE_REF-Baustein verwenden.
Szenario für Problem: Falls Sie einen bestimmten komplexen Ausdruck dem Eingang des GET_BYTE_REF-Bausteins zuweisen (siehe Beispiel), kann die Anwendung nicht geladen werden. Diese Meldung erscheint: Die Anwendung für die SPS kann nicht erstellt werden.

Beispiel
PROGRAM Test
  VAR
    structVar : StructType1;
    refToByte : REF_TO BYTE;
  END_VAR
  refToByte := GET_BYTE_REF(IN := structVar.arrayOfStructs[1].text[1]);
END_PROGRAM

TYPE
  StructType1 : STRUCT
    arrayOfStructs : ARRAY[1..1] OF StructType2;
  END_STRUCT;
  StructType2 : STRUCT
    text : STRING[10];
  END_STRUCT;	
END_TYPE

Abhilfe: nicht vorhanden

9935

Werte für Strukturelemente von globalen Variablen werden nicht in der Sicht "Variablenwerte" angezeigt.
Szenario für Problem: Wenn Sie eine globale Variable von der Sicht Instanzen in die Sicht Variablenwerte ziehen und diese globale Variable enthält Strukturelemente, zeigt die Sicht Variablenwerte keine Werte für diese Strukturelemente an.
Abhilfe: Ziehen Sie die zugehörige externe Variable in die Sicht Variablenwerte.

9971

Beim Ziehen einer Funktionsbaustein-Instanz aus der Sicht "Instanzen" in die Sicht "Variablenwerte" werden darin enthaltene Variablen von einem Array-Datentyp nicht eingefügt.
Szenario für Problem: Falls Sie eine Funktionsbaustein-Instanz aus der Sicht Instanzen in die Sicht Variablenwerte ziehen und diese Funktionsbaustein-Instanz enthält Variablen, deren Basistyp ein anwenderdefinierter Array-Datentyp ist (siehe Beispiel), werden diese Variablen nicht in die Sicht Variablenwerte eingefügt.

Beispiel
PROGRAM Test
  VAR
    iMyFBwithArray : myFBwithArray;
  END_VAR
    iMyFBwithArray();
    (* When dragging 'iMyFBwithArray' from the 'Instances' view into the 'Values of Variables' view, ... *) 
END_PROGRAM

FUNCTION_BLOCK myFBwithArray
  VAR
    Var1, Var2 : MyDTArray;
    (* ... these variables are not inserted in the view. *)
    Var3 : ARRAY [1..10] OF INT;
    (* ... In contrast: This variable is inserted in the view. *)
  END_VAR
END_FUNCTION_BLOCK

TYPE
  MyDTArray : ARRAY [1..10] OF INT;
END_TYPE

Abhilfe: Selektieren Sie die betroffenen Variablen in der Sicht Instanzen und ziehen Sie diese in die Sicht Variablenwerte. Bezogen auf das Beispiel sind das: Var1 und Var2

9977

Eine Änderung auf eine ungültige Zielsystemadresse verursacht einen infiniten Ladevorgang.
Szenario für Problem: Falls Sie eine ungültige Zielsystemadresse im SPS-Objekt eingeben und die Anwendung trotzdem laden, wird der Ladevorgang gestartet und nicht mehr beendet. Sie können den Ladevorgang auch nicht mehr in logi.CAD 3 abbrechen.

Beispiel für die Einträge im SPS-Objekt
{
  CHANNEL LocalChannel
    TCP
      ADDRESS := 0.0.0.1;     (* '0.0.0.1' is an invalid address. *)
      PORT    := 1534;
    END_TCP
  END_CHANNEL
}

Abhilfe: Beenden Sie und starten Sie logi.CAD 3 erneut. Dabei müssen Sie einen neuen Arbeitsbereich angeben. Danach importieren Sie das Projekt und tragen Sie eine gültige Zielsystemadresse ein, bevor Sie versuchen, die Anwendung erneut zu laden.

9991

Beim Ziehen einer Variable von einem Strukturdatentyp, dessen Element einen Array-Datentyp verwendet, aus der Sicht "Instanzen" in die Sicht "Variablewerte" werden solche Strukturelemente nicht eingefügt.
Szenario für Problem: Falls Sie eine Variable aus der Sicht Instanzen in die Sicht Variablenwerte ziehen und der Datentyp dieser Variable ist ein strukturierter Datentyp, von dessen Elementen ein Element einen anwenderdefinierten Array-Datentyp verwendet (siehe Beispiel), werden solche Strukturelemente nicht in die Sicht Variablenwerte eingefügt. Das gleiche Problem tritt auf, falls Sie eine Funktionsbaustein-Instanz mit solchen Variablen in die Sicht ziehen.

Beispiel
PROGRAM Test
  VAR
    iMyFBUsingStructWithArray : myFBUsingStructWithArray;
  END_VAR
  iMyFBUsingStructWithArray();
 (* When dragging ' iMyFBUsingStructWithArray' from the 'Instances' view into the 'Values of Variables' view,  *) 
 (* 'Elem1' of 'Var1' is NOT inserted. 'Elem2' of 'Var1' as well as 'Elem1' and 'Elem2' of 'Var2' are inserted. *) 
END_PROGRAM

TYPE
  MyDTArray : ARRAY [1..10] OF INT;
  MyStructWithArrayDT : STRUCT
    Elem1 : MyDTArray;
    Elem2 : INT;
  END_STRUCT;
  MyStructWithArray : STRUCT
    Elem1 : ARRAY [1..10] OF INT;
    Elem2 : INT;
  END_STRUCT;
END_TYPE

FUNCTION_BLOCK myFBUsingStructWithArray
  VAR
    Var1 : MyStructWithArrayDT;
    (* When dragging 'Var1' from the 'Instances' view into in the 'Values of Variables' view, 'Elem1' of 'Var1' is NOT inserted, 'Elem2' is inserted. *) 
    Var2 : MyStructWithArray;
    (* When dragging 'Var2' from the 'Instances' view into in the 'Values of Variables' view, 'Elem1' and 'Elem2' of 'Var2' are inserted. *)
  END_VAR
END_FUNCTION_BLOCK

Abhilfe: Klappen Sie die Variable in der Sicht Instanzen auf, selektieren Sie das betroffene Strukturelement und ziehen Sie dieses in die Sicht Variablenwerte. Bezogen auf das Beispiel sind das: Elem1 von Var1

10006

Die Inhaltshilfe bietet die Eingangs-/Ausgangsvariablen von Bausteinen u.U. nicht am Anfang der Liste zur Auswahl.
Szenario für Problem: Falls Sie die Inhaltshilfe zur Auswahl einer Eingangs-/Ausgangsvariable in einem Funktions- oder Funktionsbausteinaufruf verwenden, werden diese Variablen u.U. nicht am Anfang der Liste zur Auswahl angeboten. In diesem Fall sind alle Einträge alphabetisch sortiert.
Abhilfe: Tippen Sie den Anfangsbuchstaben der Variable ein, damit die Liste entsprechend gefiltert wird.

Bekannte Probleme in logi.CAD 3 , Version 0.57.0

IDBekanntes Problem
9577

Der Fingerprint für die Anwendung ändert sich nicht, falls C-Code in einem C-Baustein geändert wird.
Szenario für Problem: Falls Sie den C-Code in C-Bausteinen ändern, wird der Fingerprint für die Anwendung in der Sicht SPS nicht geändert. Falls die Anwendung vor dieser Änderung bereits auf die SPS geladen wurde, wird fälschlicherweise weiterhin das Symbol angezeigt.
Zusatzinformation: Der C-Code in den C-Bausteinen wird nicht von logi.CAD 3 erzeugt. Im Vergleich dazu wird der C-Code für die Schnittstelle eines C-Bausteins von logi.CAD 3 erzeugt. Bei Änderungen der Schnittstelle von C-Bausteinen wird der Fingerprint für die Anwendung geändert.
Abhilfe: nicht vorhanden