Release-Notes für Version 1.3.0

Die Release-Notes für die aktuelle Version finden Sie unter "Release-Notes für aktuelle Version".

Neuigkeiten in 1.3.0

IDNeuigkeiten
977

Unlimitierte Laufzeitlizenzen für logi.RTS auf einem Raspberry Pi werden unterstützt. Ohne aktivierte Lizenz können Sie logi.RTS als Demo-Version betreiben – die Demo-Version ist für 1 Stunde nach dem Start von logi.RTS gültig.
Wichtig: Installieren Sie die neue Version 2.3.602 von logi.RTS auf dem Raspberry Pi, bevor Sie eine Lizenz installieren. Mit früheren Versionen von logi.RTS können unvorhergesehene Terminierungen der lizenzierten logi.RTS-Version auf dem Raspberry Pi auftreten.

1184

Im ST-Editor können Datentypen vom Typ ARRAY erstellt und in Anwenderbausteinen verwendet werden. Es ist möglich, die Werte für alle Elemente einer Array-Variable in der Sicht Variablenwerte anzuzeigen.
Aktuelle Einschränkungen: Es werden nur elementare Datentypen in ein-dimensionalen Arrays unterstützt. Eine Initialisierung von Array-Elementen bei der Deklaration ist ebenfalls nicht möglich.

2547

Der Lieferumfang von logi.CAD 3 enthält nun eine integrierte SPS. Die integrierte SPS entspricht dem SPS-Laufzeitsystem "logi.RTS" von logi.cals (für Windows 7/8, 32-Bit und 64-Bit). Da die integrierte SPS automatisch gestartet wird, können Sie Ihre Programmierung noch schneller auf diese SPS übertragen und testen.
Außerdem ist eine neue Projektvorlage Zähler in logi.CAD 3 enthalten. Diese Vorlage ist für die integrierte SPS eingerichtet.

2584

Die Benutzerdokumentation von logi.CAD 3 enthält Informationen, wie Sie die Pin-Adressierung direkt auf dem Raspberry Pi herausfinden können. Außerdem enthält sie einige nützliche Links, z.B. wo Sie eine Pin-Abbildung der Raspberry Pi GPIOs finden. Diese Abbildung führt auch die Positionen der 3,3-Volt-Pins, 5-Volt-Pins und Masse-Pins auf dem Raspberry Pi an.

2766

Die Sicht Variablenwerte merkt sich, welche Variablen aus einem Projekt angezeigt werden – auch falls Sie logi.CAD 3 geschlossen haben und erneut starten. Das bedeutet: Sie müssen die Variablen nicht nach jedem Start erneut in die Sicht ziehen.

Behobene Probleme in 1.3.0

IDBehobenes Problem
2721

ST-Code wird beim Formatieren des Codes zu früh umgebrochen.
Szenario: Falls Sie bereits vorhandenen ST-Code mit dem Befehl Formatieren (im Kontextmenü) bzw. der Tastenkombination Strg+Umschalt+F formatieren, werden "längere" Aufrufe bei Zugriffen auf Ausgangsvariablen umgebrochen, obwohl dies an dieser Stelle noch nicht erforderlich ist (siehe Beispiel).
Beispiel (vor dem Formatieren):

returncode := RP_1Wire_ReadTemp(sensorGroupId := x, sensorId := y, temperature => result);

wird zu (nach dem Formatieren):

	returncode := RP_1Wire_ReadTemp(sensorGroupId := x, sensorId := y, temperature
	=> result);

Behebung: Beim Formattieren werden Aufrufe bei Zugriffen auf Ausgangsvariablen ab dem 100. Zeichen umgebrochen.

2780

Änderungen im ST-Code können Ausnahmesituation beim Laden der Programmierung verursachen
Szenario: Falls Sie das deklarierte Programm im ST-Code löschen, es ist jedoch in einem SPS-Objekt zugeordnet, kann das Laden für die betroffene SPS aus der geöffneten Sicht SPS gestartet werden. In Folge tritt eine Ausnahmesituation in logi.CAD 3 auf.
Behebung: Ein fehlerhaftes Programm kann nicht auf die betroffene SPS geladen werden. Die Ausnahmesituation wird nicht verursacht.

2783

Interne Fehlermeldung erscheint, falls kein gültiges ST-Objekt vorhanden ist.
Szenario: Falls Sie im ST-Code einen fehlerhafter Aufruf erfassen (siehe Beispiel), erscheinen die Meldungen Konnte die Referenz auf 'Name' nicht auflösen. und die interne Meldung The feature 'variable' of 'URL-Referenz' contains a dangling reference 'URL-Referenz'.
Beispiel:

PROGRAM Template
	VAR
		fbInstance : bool;
	END_VAR
	fbInstance(EN := true);
END_PROGRAM

Behebung: Die interne Meldung erscheint nicht mehr.

2806

"Programm laden" funktioniert nur, falls keine Umlaute im Projektpfad vorhanden sind
Szenario: Wenn Sie die Schaltfläche Programm laden in der Sicht SPS drücken, wird das Programm nur geladen, falls der Projektname keine Umlaute enthält. Beim Erstellen des Projekts werden Umlaute bereits verboten, allerdings können Sie derzeit noch Umlaute beim Umbenennen eines Projekts erfassen.
Behebung: Eine Meldung informiert Sie nun beim Umbenennen des Projekts, falls ungültige Zeichen im neuen Projektnamen enhalten sind. Ungültige Zeichen sind z.B. Umlaute oder Leerzeichen.

2834

Ausnahmesituation mit wiederkehrende Meldungen, falls ein Projektname das Zeichen # enthält und zur Sicht "SPS" gewechselt wird
Szenario: Falls Sie ein Projekt mit dem Zeichen # im Namen erstellen (z.B. Projekt Test#1) und zur Sicht SPS wechseln, tritt eine Ausnahmesituation in logi.CAD 3 auf (dafür werden wiederkehrende Meldungen angezeigt).
Behebung: Die wiederkehrenden Meldungen werden nicht mehr angezeigt. Projektnamen mit Zeichen # sind möglich.

2837

Allgemeine Datentypen (z.B. ANY_INT) für Strukturelemente werden nicht als Fehler gekennzeichnet.
Szenario: Wenn Sie einen strukturierten Datentypen deklarieren und dabei einen allgemeinen Datentyp (z.B. ANY_INT) erfassen, wird dieser Datentyp nicht als Fehler gekennzeichnet. Das Programm kann aber nicht geladen werden, da nur elementare Datentypen unterstützt werden.
Behebung: Allgemeine Datentypen werden als Fehler gekennzeichnet.

2851

Inhaltshilfe enthält allgemeine Datentypen zur Auswahl, obwohl diese nicht erlaubt sind.
Szenario: Wenn Sie die Inhaltshilfe verwenden, werden allgemeine Datentypen zur Auswahl angeboten, z.B. ANY_INT als Datentypen in der Deklaration von Variablen. Die Verwendung von allgemeinen Datentypen ist jedoch nicht erlaubt.
Behebung: Allgemeine Datentypen werden nicht mehr in der Liste der Inhaltshilfe angeboten.

2858

Initialisierungswerte für Strukturelemente verursachen Ausnahmesituation beim Speichern.
Szenario: Falls Sie Strukturelemente im ST-Code initialisieren (siehe Beispiel), erscheint beim Speichern ein Eintrag im Fehlerprotokoll (ohne Text). Dabei handelt es sich um eine Ausnahmesituation.
Beispiel:

TYPE
    complex : STRUCT
        re : REAL := 1;
        im : REAL := 2;
    END_STRUCT;
END_TYPE
  
PROGRAM Template
    VAR
      c : complex := (re:=1, im:=0);
    END_VAR
    c.re := 4;   
END_PROGRAM

Behebung: Die Ausnahmesituation tritt nicht mehr auf.

2861

Refactoring von Elementen im SPS-Objekt führt zu vermeintlichem Fehler.
Szenario: Falls Sie im SPS-Objekt mit dem Befehl Element umbenennen den Namen für die Elemente CONFIGURATION, RESOURCE oder TASK ändern (= Refactoring), meldet ein Dialog den Fehler Missconfigured language: New reference text has invalid syntax.
Behebung: Bei der Refactoring-Aktion tritt der oben angeführte Fehler nicht auf.

2876

Aufgetrennte Zeilen im ST-Code werden beim Formatieren des Codes zusammengehängt.
Szenario: Falls Sie bereits vorhandenen ST-Code mit dem Befehl Formatieren (im Kontextmenü) bzw. der Tastenkombination Strg+Umschalt+F formatieren, werden "aufgetrennte" Aufrufe ohne Zugriffen auf Ausgangsvariablen zu einer Zeile zusammengehängt (siehe Beispiel).
Beispiel (vor dem Formatieren):

WriteOutputs(EN := Initialized.Q1, PinBase := PinBase, Out1 := DOutput1,
		  Out2 := DOutput2, Out3 := DOutput3, Out4 := DOutput4, 
		  Out5 := DOutput5, Out6 := DOutput6, Out7 := DOutput7,
		  Out8 := DOutput8);

wird zu (nach dem Formatieren):

WriteOutputs(EN := Initialized.Q1, PinBase := PinBase, Out1 := DOutput1, Out2 := DOutput2, Out3 := DOutput3, Out4 := DOutput4, Out5 := DOutput5, Out6 := DOutput6, Out7 := DOutput7, Out8 := DOutput8);

Solche längeren Zeilen sollten umgebrochen werden.
Behebung: Beim Formattieren werden Aufrufe auch ohne Zugriffe auf Ausgangsvariablen ab dem 100. Zeichen umgebrochen.

2869

Verbesserungswürdige Meldung beim Anlegen eines Projekts, falls ungültige Zeichen im Projektpfad/-namen enhalten sind.
Szenario: Wenn Sie beim Erstellen eines Projekts ungültige Zeichen (z.B. Umlaute oder Leerzeichen) im Projektpfad/-namen erfassen, erscheint eine Meldung. Diese Meldung ist etwas missverständlich.
Behebung: Die Meldung ist aussagekräftiger.

2897

Inhalt der Sichten "Instanzen" bzw. "SPS" wird u.U. nach dem Importieren eines Projekts nicht korrekt aktualisiert.
Szenario: Falls Sie die Sichten Instanzen bzw. SPS geöffnet haben und ein Projekt importieren, wird der Inhalt der Sichten möglicherweise nicht korrekt aktualisiert. Genauere Ursachen für dieses Problem sind derzeit nicht bekannt.
Behebung: Der Inhalt der Sichten ist nach einem Import korrekt aktualisiert.

2913

Die Sicht "Variablenwerten" zeigt keine Werte für Variablen, falls die SPS nachträglich gestartet wird.
Szenario: Falls Sie Variablen in die Sicht Variablenwerte ziehen, um deren Werte zu beobachten, aber noch keine SPS läuft, werden keine Werte angezeigt. Falls Sie nun die SPS starten, werden weiterhin keine Werte angezeigt, sondern ---. Beobachtet wurde dieses Problem bei der Verwendung der integrierten SPS "logi.RTS".
Behebung: Nach dem Starten der SPS werden für das geladene Programm sofort die Werte angezeigt.

2958

Die Assistenten zum Erstellen von ST- bzw. SPS-Objekten kann sofort nach dem Start von logi.CAD 3 gestartet werden (es ist noch kein Projekt vorhanden).
Szenario: Falls im Projektexplorer noch kein Projekt vorhanden ist, ist es trotzdem möglich, den Assistenten zum Erstellen von ST- bzw. SPS-Objekten zu öffnen, z.B. mit Menü Datei, Befehl ST-Objekt. Natürlich kann der Erstellungsvorgang in den Assistenten aber nicht erfolgreich abgeschlossen werden.
Behebung: Die Befehle zum Erstellen von ST- bzw. SPS-Objekte sind nur verfügbar, falls zumindest ein Projekt im Projektexplorer vorhanden ist.

3006

Initialisierungswerte für strukturierte Variablen vom Typ "VAR_INPUT" werden beim Ausführen des Programms nicht berücksichtigt.
Szenario: Falls Sie strukturierte Variablen des Typs VAR_INPUT initialisieren (siehe Beispiel), wird dieser Initialisierungswert beim Ausführen des geladenen Programms nicht berücksichtigt. Dieses Problem tritt sowohl bei Funktionen als auch bei Funktionsbausteinen auf.
Beispiel für Funktion:

TYPE
	Range : STRUCT
		min : INT;
	END_STRUCT;
END_TYPE

FUNCTION test : INT
	VAR_INPUT
		I1 : Range := (min := 10);
                (* Diese Initialisierung wird nicht berücksichtigt. *)
	END_VAR
	
	test := I1.min;
	
END_FUNCTION

PROGRAM Template
	VAR
	result: INT;
	END_VAR
	result := test();
END_PROGRAM

Behebung: Die Initialisierungswerte werden nun beim Ausführen berücksichtigt.

3035

Nach dem Ziehen/Kopieren einer Datei aus dem Explorer des Betriebssystems in den Projektexplorer tritt u.U. eine Fehlermeldung auf.
Szenario: Falls Sie eine Datei aus dem Explorer des Betriebssystems in einen Ordner im Projektexplorer ziehen und Sie im Dialog die Option Kopiere Dateien wählen, wird möglicherweise die Meldung index=0, size=0 in der Sicht Fehlerprotokoll angezeigt. Die Datei wurde jedoch erfolgreich in das Projekt kopiert.
Zusatzinformationen: Beobachtet wurde das Problem, wenn es sich um eine iecst-Datei (= ein ST-Objekt) handelt und diese iecst-Datei strukturierte Variablen mit Initialisierungen enthält. Andere Dateien konnten gezogen/kopiert werden, ohne dass die Meldung angezeigt wird.
Behebung: Die Meldung wird nicht mehr angezeigt. Es ist jedoch sinnvoll, das Projekt trotzdem nach dem Ziehen/Kopieren von Dateien zu bereinigen.

3038

Initialisierungswerte für Strukturelemente verhindern anfänglich das Laden der Programmierung.
Szenario: Falls Sie Strukturelemente im ST-Code initialisieren (siehe Beispiel), kann das Programm für die SPS nicht erstellt und damit geladen werden.
Beispiel:

TYPE
    complex : STRUCT
        re : REAL := 1;
        im : REAL := 2;
    END_STRUCT;
END_TYPE
  
PROGRAM Template
    VAR
      c : complex := (re:=1, im:=0);
    END_VAR
    c.re := 4;   
END_PROGRAM

Behebung: Das Programm kann sofort erstellt und geladen werden.

3084

Schlüsselwörter laut IEC 61131-3 können als Bezeichner erfasst werden.
Szenario: Es ist möglich, bestimmte Schlüsselwörter aus der Norm IEC 61131-3 als Bezeichner zu erfassen (z.B. RETURN). Andere Schlüsselwörter aus IEC 61131-3 werden bereits als Bezeichner nicht zugelassen (z.B. WHILE). Es ist nicht zweckmäßig, dass manche Schlüsselwörter als Bezeichner möglich sind – vor allem, wenn diese Schlüsselwörter mit ihrer zugehörigen Syntax in logi.CAD 3 unterstützt werden.
Behebung: Eine Meldung informiert Sie, falls Sie Schlüsselwörter aus der Norm IEC 61131-3 als Bezeichner erfassen. Solche Schlüsselwörter dürfen nicht als Bezeichner verwendet werden.

3094

Inhaltshilfe zeigt falsches Symbol für Funktionen.
Szenario: Wenn Sie den Befehl Inhaltshilfe verwenden, zeigt die Liste das gleiche Symbol für Funktionsbausteine und Funktionen. Für die Funktionen muss logi.CAD 3 ein anderes Symbol zeigen.
Behebung: Ein anderes Symbol wird für die Funktionen angezeigt.

3181

logi.CAD 3 wird nicht erfolgreich gestartet, wenn Perspektive "Applikationstest" beim letzten Beenden geöffnet war.
Szenario: Falls Sie logi.CAD 3 t beenden, während die Perspektive Applikationstest geöffnet war, ist der nächste Start von logi.CAD 3 möglicherweise nicht erfolgreich. Stattdessen wird der Splash-Screen dauerhaft auf dem Bildschirm angezeigt.
Behebung: Das Problem tritt nicht mehr auf.

Bekannte Probleme in 1.3.0

ID

Bekanntes Problem

1551

Befehle zum Zurücksetzen/Wiederherstellen der ersten/letzten Zeile zeigen keine korrekte oder gar keine Funktionalität (betrifft die Schnelldifferenz)
Szenario: Wenn die Schnelldifferenz aktiviert ist (gewählter Befehl Schnelldifferenz anzeigen) und Sie die erste oder letzte Zeile des ST-Codes geändert/gelöscht haben, funktionieren die Befehle zum Zurücksetzen/Wiederherstellen der entsprechenden Zeile (z.B. Gelöschte Zeile wiederherstellen) nicht korrekt bzw. gar nicht. Diese Befehle sind im Kontextmenü für den Rand links vom Code bei den gezeigten Schnelldifferenz-Einträgen zu finden.
Abhilfe: Im Kontextmenü des ST-Editors wählen Sie Datei zurücksetzen (damit verwerfen Sie alle Änderungen seit dem letzten Speichern) oder wählen Sie Rückgängig sooft, bis wieder der ursprüngliche Code in der ersten bzw. letzten Zeile angezeigt wird.

1795

Befehl "Öffnen mit", "Direkt angezeigter Editor" nicht erfolgreich
Szenario: Wenn Sie im Kontextmenü des Projektexplorers den Befehl Öffnen mit und Direkt angezeigter Editor wählen (z.B. für ein ST-Objekt), wird folgende Meldung angezeigt: Wiederherstellen des direkten Editors nicht möglich. Direktunterstützung fehlt
Abhilfe: Verwenden Sie den Befehl Öffnen mit und ST-Editor, um ST-Objekte und SPS-Objekte zu öffnen. Für andere Objekte, wie z.B. Textdateien, können Sie den Befehl Öffnen mit und Texteditor verwenden.

1843

Englischer Text "Whole word" im Dialog "Suchen"
Szenario: In der deutschen Sprachversion enthält der Dialog Suchen die Option Whole word (englische Bezeichnung für "Ganzes Wort").

1844

"Umbenennen" und "Löschen" im Projektexplorer nach dem Starten von logi.CAD 3 möglich
Szenario: Nach dem Starten von logi.CAD 3 können Sie die Befehle Umbenennen bzw. Löschen aufrufen (aus dem Menü Datei bzw. Bearbeiten oder via Tastenkombination F2 bzw. Entf), obwohl diese keine sinnvolle Funktionalität haben.
Zusatzinformation: Dieses Problem tritt auch auf, falls Sie einen neuen Arbeitsbereich wählen oder den Arbeitsbereich wechseln und im Projektexplorer sind keine Projekte enthalten.
Abhilfe: Erstellen Sie ein Projekt und selektieren Sie zumindest eine Ressource darin, bevor Sie den entsprechenden Befehl aufrufen.

1920

Fehlermeldung beim Umbenennen von Projekten, die nicht im Arbeitsbereich liegen
Szenario: Wenn Sie ein Projekt außerhalb des Arbeitsbereichs erstellt haben und dieses anschließend umbenennen, werden interne Fehler angezeigt, dass die Datei .project (im Arbeitsbereich) für das Projekt nicht vorhanden ist. Das Umbenennen selbst hat jedoch funktioniert.
Zusatzinformation: Das Problem wird durch verlinkte Ordner verursacht, die Systembausteine enthalten. Beispiele für solche Ordner: IEC61131-3, Raspberry Pi IO. Diese verlinkten Ordner müssen jedoch im Projekt vorhanden sein, damit Sie Systembausteine in Ihrem ST-Code verwenden können.
Abhilfe (empfohlen, um die Meldung zu vermeiden):

  • Löschen Sie solche verlinkten Ordner im Projekt, das Sie umbenennen wollen.
  • Benennen Sie das Projekt um.
  • Erstellen Sie ein temporäres Projekt, das die verlinkten Ordner enthält.
  • Ziehen Sie die verlinkten Ordner aus dem temporären Projekt in das umbenannte Projekt.
  • Löschen Sie das temporäre Projekt.

Abhilfe (falls die Meldung bereits aufgetreten ist):

  • Im Explorer des Betriebssystems: Gehen Sie zum Ordner, der in der Meldung genannt wird und die Datei .project enthält. Löschen Sie diesen Ordner.
  • Löschen Sie die internen Fehler aus der Sicht Fehlerprotokoll.
2470

Sichten "SPS", "Instanzen" und "Variablenwerte" unterstützen einige Tastenkombinationen nicht
Szenario: Folgende Tastenkombinationen haben keine Funktion in den Sichten SPS, Instanzen und Variablenwerte.

Tastenkombination

Funktion

Alt+-

System-Menü der Sicht anzeigen

F12

von Sicht zum aktuellen Editor wechseln

Strg+F7

nächste Sicht

Strg+Umschalt+F7

vorherige Sicht

Strg+F10

Menü für Sicht anzeigen

Strg+M

aktuelle Sicht zwischen maximiertem und wiederhergestelltem Zustand umschalten

Abhilfe: Verwenden Sie die Maus, um die gewünschte Funktion in den genannten Sichten auszulösen.

2473

Bestimmte Tastenkombinationen in Sichten "SPS", "Instanzen" und "Variablenwerte" zeigen die Auswahlliste immer auf dem Hauptbildschirm.
Szenario: Wenn Sie in den Sichten SPS, Instanzen und Variablenwerte die folgenden Tastenkombinationen drücken, erscheint eine Auswahlliste. Diese Auswahlliste erscheint immer auf dem Hauptbildschirm, auch wenn logi.CAD 3 auf dem 2. Bildschirm angezeigt wird.

Tastenkombination

Funktion

Strg+F6

nächster Editor

Strg+Umschalt+F6

vorheriger Editor

Strg+F8

nächste Perspektive

Strg+Umschalt+F8

vorherige Perspektive

Abhilfe: Verwenden Sie die entsprechenden Befehle im Menü Fenster, um die gewünschte Funktion in den genannten Sichten auszulösen.

2752

Kommentare werden beim Formatieren des Codes nicht zueinander ausgerichtet. Bei einem Kommentar am Anfang der Datei wird eine Leerzeile eingefügt.
Szenario: Falls Sie bereits vorhandenen ST-Code mit dem Befehl Formatieren (im Kontextmenü) bzw. der Tastenkombination Strg+Umschalt+F formatieren, werden Kommentare im ST-Code u.U. nicht zueinander ausgerichtet (siehe Beispiel).
Beispiel (vor dem Formatieren):

FUNCTION_BLOCK FUB_LEDCylon
    /*
     * The LEDs are shifted back and forth.
     */
END_FUNCTION_BLOCK

wird zu (nach dem Formatieren):

FUNCTION_BLOCK FUB_LEDCylon
/*
     * The LEDs are shifted back and forth.
     */
END_FUNCTION_BLOCK

Falls außerdem am Anfang der Datei ein Kommentar vorhanden ist, wird eine Leerzeile vor diesem Kommentar eingefügt. Dadurch beginnt die Datei mit einer Leerzeile.
Abhilfe: nicht vorhanden

2809

Verlinkte Ordner werden beim Exportieren eines Projekts in eine Archivdatei berücksichtigt.
Szenario: Falls Sie ein Projekt in eine Archivdatei exportieren, wird der Inhalt von verlinkten Ordner (z.B. IEC61131-3 mit den IEC-Bausteinen) ebenfalls exportiert. Falls Sie anschließend das Projekt aus der Archivdatei importieren, sind die zuvor verlinkten Ordner zu "eigentlichen" Ordnern im Projekt geworden. In Folge treten möglicherweise Probleme auf, wenn Sie die Objekte verwenden, die im (eigentlich verlinkten) Ordner liegen; z.B. wenn Sie die IEC-Bausteine im ST-Code erfassen.
Abhilfe: Beim Exportieren in eine Archivdatei klappen Sie das zu exportierende Projekt in der linken Liste des Dialogs auf, entfernen Sie die Markierung für die verlinkten Ordner und drücken Sie erst dann Fertigstellen, um den Export zu starten. Nach dem Importieren sind die verlinkten Ordner im Projekt automatisch vorhanden.

2894

Keine Tastaturbedienung für "Quick-Info anzeigen"
Szenario: Falls Sie einen Mauszeiger auf ein Element im ST-Editor bewegen, wird eine Quick-Info angezeigt (auch als "Tooltip" oder "Hover-Text" bezeichnet). Sie können diese Quick-Info nicht mit Hilfe der Tastatur anzeigen.
Abhilfe: nicht vorhanden

3015

Befehl "Properties" in der Schnellzugriff-Suchleiste verursacht Fehlermeldung, wenn Sicht "SPS", "Instanzen" oder "Variablenwerte" aktiv.
Szenario: Wenn die Sicht SPS, Instanzen oder Variablenwerte den aktuellen Fokus hat und Sie den Befehl Properties (in Kategorie Befehle verfügbar) in der Schnellzugriff-Suchleiste eingeben/auswählen, erscheint eine interne Fehlermeldung.
Zusatzinformation: Der Befehl Properties öffnet die Sicht Properties, wenn ein Objekt z.B. im Projektexplorer selektiert ist. Derzeit wird dies für die Sichten SPS, Instanzen und Variablenwerte nicht unterstützt.
Abhilfe: Bestätigen Sie die interne Fehlermeldung.
Anhand der verfügbaren Befehle unter Menü Navigieren, Anzeigen in können Sie prüfen, ob die Sicht Properties im aktuellen Kontext geöffnet werden kann. Falls der Befehl Properties verfügbar ist, ist das Öffnen der Sicht möglich. Falls der Befehl Properties nicht verfügbar ist, ist es nicht möglich.

3052

Inhaltshilfe innerhalb der Deklaration von Funktionen enthält Funktionen und Funktionsbausteine zur Auswahl, wo diese nicht erlaubt sind.
Szenario: Wenn Sie innerhalb der Deklaration einer Funktion die Inhaltshilfe beim Deklarieren von Variablen verwenden (siehe Beispiel), werden Funktionen und Funktionsbausteine zur Auswahl angeboten, z.B. ADD oder TOF. Die Verwendung von Funktionen und Funktionsbausteine ist dort jedoch nicht erlaubt.
Beispiel:

FUNCTION fun1 : INT
  VAR
  a:   (* Hier bietet die Inhaltshilfe fälschlicherweise Funktionen und Funktionsbausteine. *)
  END_VAR
END_FUNCTION

Abhilfe: Wenn Sie eine Funktion oder einen Funktionsbausteine aus der Inhaltshilfe gewählt haben, wird die Zeile als fehlerhaft markiert. Ersetzen Sie die Funktion oder den Funktionsbaustein durch einen der unterstützten Datentypen (z.B. BOOL).

3070

Beim Refactoring von Bezeichnern auf reservierte Schlüsselwörter wird keine anwenderfreundliche Meldung angezeigt.
Szenario: Falls Sie einen Bezeichner mit dem Befehl Element umbenennen ändern (= Refactoring) und dabei ein reserviertes Schlüsselwort erfassen (z.B. WHILE), meldet ein Dialog den Fehler Illegal name: The value 'WHILE' is an invalid IEC_IDENTIFIER. Diese Meldung ist derzeit in Englisch und enthält den internen Begriff IEC_IDENTIFIER. Falls das erfasste Schlüsselwort nur aus 2 Buchstaben besteht (z.B. IF), wird gar keine Meldung angezeigt.
Die Refactoring-Aktion wird – korrekterweise – nicht durchgeführt. Daher bleibt der ursprüngliche Bezeichner erhalten.
Abhilfe: Erfassen Sie einen Bezeichner, der kein reserviertes Schlüsselwort ist. Die Liste der reservierten Schlüsselwörter finden Sie in der Referenzdokumentation: Reservierte Schlüsselwörter in ST

3081

Eingangsvariable können beschrieben werden.
Szenario: Sie können ST-Code erfassen, mit dem Eingangsvariablen (in VAR_INPUT ... END_VAR deklariert) beschrieben werden können. Laut der Norm IEC 61131-3 darf dies nicht möglich sein.
Abhilfe: nicht vorhanden

3098

"Programm laden" funktioniert nicht, falls eine deklarierte Funktion als ARRAY-Index aufgerufen wird.
Szenario: Wenn Sie die Schaltfläche Programm laden in der Sicht SPS drücken, kann das Programm für die SPS nicht erstellt werden, falls eine Funktion deklariert ist und diese wird als ARRAY-Index aufgerufen (siehe Beispiel).
Beispiel:

PROGRAM Template
	VAR Var1 : ARRAY [5..7] OF SINT; END_VAR
	Var1[Fun()] := 4;  (* Die Funktion wird als ARRAY-Index aufgerufen. *)
END_PROGRAM
FUNCTION Fun : INT
	Fun := 4;
END_FUNCTION

Abhilfe: Deklarieren Sie im Programm eine Hilfs-Variable vom Datentyp INT, weisen Sie den Funktionsaufruf der Variable zu und erfassen Sie die Hilfs-Variable als Array-Index (siehe Beispiel).
Beispiel:

PROGRAM Template
	VAR Var1 : ARRAY [5..7] OF SINT;
	helper : INT;       (* Deklaration der Hilfs-Variable *)
	END_VAR
	helper := Fun();    (* Aufruf der Funktion der Hilfs-Variable zuweisen *)
	Var1[helper] := 4;  (* Die Hilfs-Variable wird als ARRAY-Index aufgerufen. *)
END_PROGRAM
FUNCTION Fun : INT
	Fun := 4;
END_FUNCTION
3101

Bei negativen ARRAY-Indizes wird das falsche ARRAY-Element verwendet.
Szenario: Falls Sie einen negativen ARRAY-Index verwenden (siehe Zuweisung im folgenden Beispiel), wird das falsche ARRAY-Element verwendet. Außerdem wird der Ausgang ENO der umfassenden POE auf den Wert FALSE gesetzt.
Beispiel:

FUNCTION_BLOCK Test
	VAR
		Var1 : ARRAY [-3..5] of INT;
	END_VAR
	Var1[-3] := 10;  (* Es wird nicht das ARRAY-Element '-3' verwendet, sondern '5'; außerdem: 'ENO' von 'Test' = 'FALSE' *)
END_FUNCTION_BLOCK

Abhilfe: Deklarieren Sie derzeit ARRAY-Datentypen und ARRAY-Variablen mit einem Index-Unterbereich, der nur positive Werte enthält. Beispiel:

FUNCTION_BLOCK Test
	VAR
		Var1 : ARRAY [1..9] of INT;
	END_VAR
	Var1[1] := 10; 
END_FUNCTION_BLOCK
3104

Unklare Meldung, wenn eine ARRAY-Variable verwendet, aber nicht deklariert ist.
Szenario: Falls Sie eine ARRAY-Variable verwenden, die nicht deklariert ist, wird die Verwendung als fehlerhaft markiert. Eine der angezeigten Meldungen ist Die Variable "null" ist kein Array. – Diese Meldung mit null ist unklar.
Beispiel:

PROGRAM Template
	arrayVar[1] := 4;
END_PROGRAM

Zusatzinformation: Eine Meldung, die ebenfalls angezeigt wird, nennt bereits den Namen der Variable: Konnte die Referenz auf "arrayVar" nicht auflösen.
Abhilfe: Deklarieren Sie die ARRAY-Variable.
Beispiel:

PROGRAM Template
	VAR
	   arrayVar : ARRAY [1..5] of INT;
	END_VAR
	arrayVar[1] := 4;
END_PROGRAM
3107

Keine Wert-Anzeige für lokale Variablen von Systembausteinen
Szenario: Wenn Sie im ST-Code einen Standardfunktionsbaustein verwenden, werden dessen Variablen in der Sicht Instanzen angezeigt. Falls Sie eine lokale Variable in die Sicht Variablenwerte ziehen, werden für diese lokale Variable keine Werte angezeigt. Beispiel: Beim Systembaustein CTD ist CU_M eine lokale Variable.
Zusatzinformation: Sie erkennen die lokalen Variablen anhand des entsprechenden Symbols in der Sicht Instanzen.
Abhilfe: nicht vorhanden

3110

Initialisierungsfehler bei globalen Variablen werden nicht gekennzeichnet.
Szenario: Wenn Sie eine globale Variable initialisieren, werden fehlerhafte Angaben nicht als Fehler gekennzeichnet bzw. Werte ohne Typangaben werden nicht validiert. Wenn Sie die Schaltfläche Programm laden in der Sicht SPS drücken, kann das Programm für die SPS nicht erstellt werden.

Beispiel 1: Fehlerhafte Angabe

Beispiel 2: Wert ohne Typangabe

VAR_GLOBAL
	GVar1 : bool := 5;
END_VAR
VAR_GLOBAL
	GVar1 : INT := 5;
END_VAR

Abhilfe: Erfassen Sie die Werte, die laut dem Datentyp möglich sind – am besten mit der entsprechenden Typangabe.

Beispiel 1: Angabe laut Datentyp

Beispiel 2: Wert mit Typangabe

VAR_GLOBAL
	GVar1 : bool := TRUE;
END_VAR
VAR_GLOBAL
	GVar1 : INT := INT#5;
END_VAR
3113

Zu große Portnummer im SPS-Objekt wird nicht als Fehler gekennzeichnet.
Szenario: Wenn Sie eine zu große Portnummer im SPS-Objekt erfassen, ist die Schaltfläche Programm laden in der Sicht SPS deaktiviert. Die zu große Portnummer wird jedoch nicht als Fehler gekennzeichnet.
Beispiel:

PORT    := 1000000000;

Abhilfe: Erfassen Sie eine gültige Portnummer und speichern Sie das SPS-Objekt. Falls die Schaltfläche Programm laden weiterhin deaktiviert ist, schließen und starten Sie logi.CAD 3 erneut.

3125

Deklarierte Variablen werden beim Formatieren des Codes in einer Zeile angeordnet.
Szenario: Falls Sie bereits vorhandenen ST-Code mit dem Befehl Formatieren (im Kontextmenü) bzw. der Tastenkombination Strg+Umschalt+F formatieren, werden die Abschnitte der deklarierten Variablen zu einer Zeile (siehe Beispiel).
Beispiel (vor dem Formatieren):

	VAR
		x : int; 
		returncode : int; 
	END_VAR

wird zu (nach dem Formatieren):

	VAR x : int; returncode : int; END_VAR

Abhilfe: nicht vorhanden

3152

Nach dem Ziehen/Kopieren einer Datei aus dem Explorer des Betriebssystems in den Projektexplorer ist der Inhalt der Sichten "Instanzen" und "SPS" nicht aktuell.
Szenario: Falls Sie eine Datei aus dem Explorer des Betriebssystems in einen Ordner im Projektexplorer ziehen und Sie im Dialog die Option Kopiere Dateien wählen, zeigen die Sichten Instanzen und SPS nicht den Inhalt der kopierten Datei.
Abhilfe: Bereinigen Sie das Projekt (Menü Projekt, Bereinigen...).

3158

Verzögerungen beim Einfügen von Instanzen mit ARRAY-Variablen in die Sicht "Variablenwerte" und anschließendem Löschen aller Variablen
Szenario: Wenn Sie eine Instanz eines Funktionsbausteins aus der Sicht Instanzen in die Sicht Variablenwerte ziehen und diese Instanz enthält zumindest eine ARRAY-Variable mit mehr als 100 ARRAY-Elemente, werden alle Variablen der Instanz eingefügt – auch alle ARRAY-Elemente. Diese Anzeige kann eine leichte Verzögerung für die Interaktion mit logi.CAD 3 verursachen. Für das anschließende Löschen aller Variablen in der Sicht (inkl. der ARRAY-Elemente) benötigt logi.CAD 3 ebenfalls etwas Zeit.
Abhilfe für das Einfügen: Markieren Sie in der Sicht Instanzen nur jene Variablen, deren Werte Sie beobachten wollen, und ziehen Sie diese Variablen in die Sicht Variablenwerte.
Abhilfe für das Löschen: Klappen Sie die hierarchische Ebene zu (z.B. das Projekt), markieren Sie diese Ebene und drücken Sie die Entf-Taste.

3184

Windows security alerts appear when starting logi.CAD 3 .
Scenario: When starting logi.CAD 3 for the first time, the Windows security alert The Windows Firewall has blocked some features of this program appears – for RTSLoader.exe as well as for logiCAD3 .exe.
Workaround: Click Allow access so that the built-in PLC is automatically started and you can use it in logi.CAD 3 .

3189

Das Verschieben von ST-Code verursacht eine Ausnahmesituation.
Szenario: Falls Sie ST-Code im ST-Objekt verschieben (mit Hilfe von "Drag and Drop"), tritt eine Ausnahmesituation in logi.CAD 3 auf. In der Sicht Fehlerprotokoll erscheint die Meldung Unhandled event loop exception. Der ST-Code wird nicht verschoben.
Abhilfe: Verschieben Sie den ST-Code mit Hilfe der Befehle Ausschneiden und Einfügen (im Kontextmenü).

3197

Wiederaufgenommene Verbindung zu Raspberry Pi verursacht einige Male wechselnde Anzeige in Perspektive "Applikationstest".
Szenario: Wenn eine bereits vorhandene Verbindung zu Raspberry Pi unterbrochen und erneut aufgenommen wird (z.B. ein gelöstes Netzwerkkabel wird wieder angesteckt), so wechselt (question) einige Male die Anzeige in den Sichten SPS und Variablenwerte, bevor abschließend die Anzeige für die korrekte Verbindung aktiv bleibt. Dann wird in den Sichten SPS und Variablenwerte das Symbol (tick) angezeigt.
Abhilfe: nicht vorhanden

3200

Trotz wiederaufgenommener Verbindung zu Raspberry Pi werden u.U. keine Werte in der Sicht "Variablenwerte" angezeigt.
Szenario: Wenn eine bereits vorhandene Verbindung zu Raspberry Pi unterbrochen und erneut aufgenommen wird (z.B. ein gelöstes Netzwerkkabel wird wieder angesteckt), so werden u.U. keine Werte in der Sicht Variablenwerte* angezeigt (sondern ---), obwohl das Symbol (tick) angezeigt wird.
Abhilfe: Möglicherweise werden die Werte angezeigt, wenn Sie die Perspektive Applikationstest schließen und erneut öffnen. Ist das nicht der Fall, starten Sie den Raspberry Pi erneut.

3226

Die Sicht "Variablenwerte" zeigt keine Werte, falls Programm mit REAL-Werten auf dem Raspberry Pi ausgeführt wird und die Sicht einen REAL-Wert enthält.
Szenario: Die Sicht Variablenwerte zeigt keine Werte (sondern ---), falls das Programm REAL-Werte enthält (siehe Beispiel), es auf einem Raspberry Pi geladen wurde und zumindest ein REAL-Wert in die Sicht zur Beobachtung gezogen wurde.
Beispiel:

PROGRAM Test
   VAR
      r : REAL;
   END_VAR
   r := r + 1.1;
END_PROGRAM

Abhilfe: Aktivieren Sie en_GB.UTF-8 UTF-8 als "locale" für den Raspberry Pi. Eine Anleitung finden Sie in der Referenzdokumentation unter Raspberry Pi konfigurieren, Optionen für Raspberry Pi einstellen.
Um schneller zur Liste der locales des Raspberry Pis zu gelangen, erfassen Sie im Terminal-Fenster von PuTTY diesen Befehl: dpkg-reconfigure locales

3233

Das Importieren von großen Projekten verursacht u.U. eine Ausnahmesituation.
Szenario: Beim Importieren von großen Projekten tritt u.U. eine Ausnahmesituation in logi.CAD 3 auf. Das Importieren selbst ist erfolgreich. Genauere Ursachen für diese Ausnahmesituation sind derzeit nicht bekannt.
Abhilfe: Bereinigen Sie das Projekt (Menü Projekt, Bereinigen...).