Release-Notes für Version 1.1.0

Die Release-Notes für die aktuelle Version finden Sie unter "Release-Notes für aktuelle Version".

Neuigkeiten in Version 1.1.0

IDNeuigkeiten

2570

logi.CAD 3 benötigt eine installierte "Java Runtime Environment (JRE) 7" (bzw. 1.7). JRE ist nun im Lieferumfang von logi.CAD 3 enthalten (JRE wird also automatisch mitinstalliert).

2577

Die Benutzerdokumentation von logi.CAD 3 enthält eine Kurzanleitung, um einen Raspberry Pi in Betrieb zu nehmen und logi.RTS darauf zu installieren und zu starten.
Außerdem sind neue Projektvorlagen für Raspberry Pi in logi.CAD 3 enthalten. Mit der Vorlage LEDs ein-/ausschalten und der Kurzanleitung können Sie ein Raspberry-Pi-Konstrukt realisieren, bei dem Sie durch Drücken/Loslassen eines Druckknopfes eine LED ein- und ausschalten können.

Behobene Probleme in Version 1.1.0

IDBehobenes Problem
1910

"Anzeigen in (Instanzen)" in Schnellzugriff verursacht Fehler
Szenario: Falls Sie einen Editor geöffnet haben und den Befehl Anzeigen in (Instanzen) im Feld für Schnellzugriff eingeben/auswählen, tritt ein Fehler auf.
Behebung: Der Fehler tritt nicht mehr auf.

2602

"Programm laden" funktioniert nur, falls keine Umlaute im Projektpfad vorhanden sind
Szenario: Wenn Sie die Schaltfläche Programm laden in der Sicht SPS drücken, wird das Programm nur geladen, falls das Projekt in einem Verzeichnis ohne Umlaute erstellt wurde.
Behebung: Eine Meldung informiert Sie nun beim Anlegen des Projekts, falls ungültige Zeichen im Projektpfad enhalten sind. Ungültige Zeichen sind z.B. Umlaute oder Leerzeichen.

2615

Löschen von mehreren/allen Variablen aus Sicht "Variablenwerte" verursacht Fehlermeldungen.
Szenario: Wenn Sie mehrere bzw. alle Variablen in der Sicht Variablenwerte selektieren (durch das Halten der Umschalt- oder Strg-Taste bzw. durch das Drücken von Strg+A) und diese durch das Drücken der Entf-Taste aus der Sicht löschen, werden in der Sicht Fehlerprotokoll mehrere Meldungen Ungültiges Zielsystem-Kommando angezeigt.
Behebung: Das Löschen von mehreren/allen Variablen aus der Sicht Variablenwerte ist nach dem Selektieren dieser Variablen wie oben beschrieben wieder möglich.

2612

Inhaltshilfe enthält EN bzw. ENO für Funktionen zur Auswahl, obwohl diese in diesem Kontext nicht erlaubt sind.
Szenario: Wenn Sie die Inhaltshilfe außerhalb eines Funktionsaufrufs verwenden, wird der Eingang EN bzw. der Ausgang ENO zur Auswahl angeboten. Die Verwendung von EN bzw. ENO ist jedoch nur im Funktionsaufruf erlaubt.
Behebung: Der Eingang EN bzw. der Ausgang ENO einer Funktion wird bei der Inhaltshilfe nur zur Auswahl angeboten, wenn Sie sich im Aufruf dieser Funktion befinden.

2622

"Programm laden" für Raspberry-Pi- und Beckhoff-CX9020-Projekte funktioniert nur, falls keine Leerzeichen im Namen des Installationsverzeichnis vorhanden
Szenario: Wenn Sie die Schaltfläche Programm laden in der Sicht SPS drücken, wird das Programm eines Raspberry-Pi- bzw. Beckhoff-CX9020-Projekts nur geladen, falls logi.CAD 3 in ein Verzeichnis ohne Leerzeichen installiert wurde.
Behebung: Das Installationsverzeichnis darf Leerzeichen enthalten, auch falls Sie Raspberry-Pi- oder Beckhoff-CX9020-Projekte erstellen.

2630

Inhaltshilfe in SPS-Objekt bietet Liste der Plattformen nicht, wenn bereits Buchstaben erfasst sind.
Szenario: Wenn Sie die Inhaltshilfe zum Erfassen einer Plattform innerhalb eines SPS-Objekts verwenden und Sie haben Buchstaben im Editor erfasst (zur Einschränkung der Elemente, die die Inhaltshilfe anbietet), werden die möglichen Plattformen nicht angeboten.

Beispiel
	RESOURCE local ON R (* Nach 'R' sollte die Inhaltshilfe die Liste der Plattformen anbieten. *)

Behebung: Die Inhaltshilfe in einem SPS-Objekt bietet nun die entsprechende Liste der Plattformen, auch wenn bereits Buchstaben erfasst sind.

2634

Flackernde Sicht "SPS" (bei Aktualisierungen des SPS-Objekts)
Szenario: Falls das SPS-Objekt bearbeitet wird, ist eine flackernde Anzeige der Sicht SPS möglich. Genauere Ursachen für dieses Problem sind derzeit nicht bekannt.
Behebung: Das Bearbeiten des SPS-Objekts ist nun möglich, während die Sicht SPS angezeigt wird. Die flackernde Anzeige wurde nicht mehr festgestellt.

2637

Ein Projekt mit Konvertierungsbausteinen kann nicht auf einen Raspberry Pi geladen werden.
Szenario: Falls Sie einen Konvertierungsbaustein (z.B. TO_INT) im ST-Code verwenden, ist es nicht möglich, das Programm auf einen Raspberry Pi zu laden.
Behebung: Ein Projekt mit Konvertierungsbausteinen kann auf einen Raspberry Pi geladen werden.

2640

Die Systembausteine können im Projektexplorer gelöscht werden.
Szenario: Wenn im Projektexplorer ein Systembaustein selektiert ist (z.B. der RS-Baustein), können Sie den Befehl Löschen aufrufen (aus dem Menü Bearbeiten und via Tastenkombination Entf). In Folge ist der Systembausteine nicht mehr verfügbar.
Behebung: Verwenden Sie den Befehl Aus lokalem Protokoll wiederherstellen... (im Kontextmenü des Projekts), um die gelöschten Systembausteine aus dem lokalem Protokoll wiederherzustellen. Die detaillierte Vorgehensweise finden Sie in der Referenzdokumentation.

2643

Fehlermeldung Error Executing EValidator erscheint, falls kein gültiges ST-Objekt vorhanden ist.
Szenario: Wenn Sie bei einer Zuweisung im ST-Code den Namen einer Variable erfassen, für die keine Deklaration vorhanden ist, erscheinen die Meldungen Konnte die Referenz auf 'Name' nicht auflösen. und die interne Meldung Error executing EValidator.
Behebung: Die Fehlermeldung Typ des Sprachelements kann nicht aufgelöst werden. erscheint statt der internen Meldung, also zusätzlich zu Konnte die Referenz auf 'Name' nicht auflösen.

2653

Fehlermeldung First position: 'NAME' at xx, this position: 'NAme' at yy erscheint beim Refactoring eines Bezeichners mit unterschiedlicher Groß-/Kleinschreibung im gleichen ST-Objekt.
Szenario: Falls Sie mit dem Befehl Element umbenennen (= Refactoring) einen Bezeichner mit unterschiedlicher Groß-/Kleinschreibung (= "Case-Insensitiver" Bezeichner) ändern (siehe Beispiel) und alle Elemente befinden sich im gleichen ST-Objekt, wird fälschlicherweise der Fehler First position: 'NAME' at xx, this position: 'NAme' at yy in der Sicht Fehlerprotokoll angezeigt. Die Refactoring-Aktion selbst wird korrekt durchgeführt.
Beispiel:

PROGRAM Template
	Test();   (* Refactoring-Aktion wird für diesen Bezeichner mit unterschiedlicher Groß-/Kleinschreibung ausgelöst. *)
END_PROGRAM
FUNCTION test : int
END_FUNCTION

Behebung: Umbenannte Bezeichner mit unterschiedlicher Groß-/Kleinschreibung, die im gleichen ST-Objekt sind, werden nicht mehr fälschlicherweise als Fehler markiert.

2657

Physikalische Adressen in Deklaration von globalen Variablen ändern nicht die Identifikation (den Fingerprint) der IEC-Ressource in Sicht "SPS"
Szenario: Wenn Sie ST-Code ändern und speichern, zeigt die Sicht SPS in der Spalte Identifikation einen geänderten Fingerprint für die IEC-Ressource. Dadurch können Sie erkennen, dass der Stand der Programmierung, die auf die SPS geladen ist, unterschiedlich zu jenem in logi.CAD 3 ist. Falls Sie nur physikalische Adressen bei der bereits vorhandenen Deklaration von globalen Variablen erfassen, löschen oder ändern, fließen diese Modifikationen nicht in die Berechung des Fingerprints ein. Das bedeutet, dass der Stand irrtümlich als identisch gekennzeichnet wird.
Behebung: Bei Manipulationen von physikalischen Adressen in der Deklaration von globalen Variablen wird die Identifikation (der Fingerprint) nun geändert.

Bekannte Probleme in Version 1.1.0

ID

Bekanntes Problem

1551

Befehle zum Zurücksetzen/Wiederherstellen der ersten/letzten Zeile zeigen keine korrekte oder gar keine Funktionalität (betrifft die Schnelldifferenz)
Szenario: Wenn die Schnelldifferenz aktiviert ist (gewählter Befehl Schnelldifferenz anzeigen) und Sie die erste oder letzte Zeile des ST-Codes geändert/gelöscht haben, funktionieren die Befehle zum Zurücksetzen/Wiederherstellen der entsprechenden Zeile (z.B. Gelöschte Zeile wiederherstellen) nicht korrekt bzw. gar nicht. Diese Befehle sind im Kontextmenü für den Rand links vom Code bei den gezeigten Schnelldifferenz-Einträgen zu finden.
Abhilfe: Im Kontextmenü des ST-Editors wählen Sie Datei zurücksetzen (damit verwerfen Sie alle Änderungen seit dem letzten Speichern) oder wählen Sie Rückgängig sooft, bis wieder der ursprüngliche Code in der ersten bzw. letzten Zeile angezeigt wird.

1795

Befehl "Öffnen mit", "Direkt angezeigter Editor" nicht erfolgreich
Szenario: Wenn Sie im Kontextmenü des Projektexplorers den Befehl Öffnen mit und Direkt angezeigter Editor wählen (z.B. für ein ST-Objekt), wird folgende Meldung angezeigt: Wiederherstellen des direkten Editors nicht möglich. Direktunterstützung fehlt
Abhilfe: Verwenden Sie den Befehl Öffnen mit und ST-Editor, um ST-Objekte und SPS-Objekte zu öffnen. Für andere Objekte, wie z.B. Textdateien, können Sie den Befehl Öffnen mit und Texteditor verwenden.

1843

Englischer Text "Whole word" im Dialog "Suchen"
Szenario: In der deutschen Sprachversion enthält der Dialog Suchen die Option Whole word (englische Bezeichnung für "Ganzes Wort").

1844

"Umbenennen" und "Löschen" im Projektexplorer möglich, wenn keine Ressourcen selektiert sind
Szenario: Wenn im Projektexplorer keine Ressourcen selektiert sind, können Sie die Befehle Umbenennen bzw. Löschen aufrufen (aus dem Menü Datei bzw. Bearbeiten und via Tastenkombination F2 bzw. Entf), obwohl diese keine sinnvolle Funktionalität haben.
Abhilfe: Selektieren Sie zumindest eine Ressource im Projektexplorer, bevor Sie den Befehl aufrufen.

1920

Fehlermeldung beim Umbenennen von Projekten, die nicht im Arbeitsbereich liegen
Szenario: Wenn Sie ein Projekt außerhalb des Arbeitsbereichs erstellt haben und dieses anschließend umbenennen, werden interne Fehler angezeigt, dass die Datei .project (im Arbeitsbereich) für das Projekt nicht vorhanden ist. Das Umbenennen selbst hat jedoch scheinbar funktioniert.
Abhilfe: Ignorieren Sie den internen Fehler (wie in der Benutzerdokumentation unter "Projekt umbenennen" dokumentiert).

2470

Sichten "SPS", "Instanzen" und "Variablenwerte" unterstützen einige Tastenkombinationen nicht
Szenario: Folgende Tastenkombinationen haben keine Funktion in den Sichten SPS, Instanzen und Variablenwerte.

Tastenkombination

Funktion

Alt+-

System-Menü der Sicht anzeigen

F12

von Sicht zum aktuellen Editor wechseln

Strg+F7

nächste Sicht

Strg+Umschalt+F7

vorherige Sicht

Strg+F10

Menü für Sicht anzeigen

Strg+M

aktuelle Sicht zwischen maximiertem und wiederhergestelltem Zustand umschalten

Abhilfe: Verwenden Sie die Maus, um die gewünschte Funktion in den genannten Sichten auszulösen.

2473

Bestimmte Tastenkombinationen in Sichten "SPS", "Instanzen" und "Variablenwerte" zeigen die Auswahlliste immer auf dem Hauptbildschirm.
Szenario: Wenn Sie in den Sichten SPS, Instanzen und Variablenwerte die folgenden Tastenkombinationen drücken, erscheint eine Auswahlliste. Diese Auswahlliste erscheint immer auf dem Hauptbildschirm, auch wenn logi.CAD 3 auf dem 2. Bildschirm angezeigt wird.

Tastenkombination

Funktion

Strg+F6

nächster Editor

Strg+Umschalt+F6

vorheriger Editor

Strg+F8

nächste Perspektive

Strg+Umschalt+F8

vorherige Perspektive

Abhilfe: Verwenden Sie die entsprechenden Befehle im Menü Fenster, um die gewünschte Funktion in den genannten Sichten auszulösen.

2721

ST-Code wird beim Formatieren des Codes zu früh umgebrochen.
Szenario: Falls Sie bereits vorhandenen ST-Code mit dem Befehl Formatieren (im Kontextmenü) bzw. der Tastenkombination Strg+Umschalt+F formatieren, werden "längere" Aufrufe bei Zugriffen auf Ausgangsvariablen umgebrochen, obwohl dies an dieser Stelle noch nicht erforderlich ist (siehe Beispiel).
Beispiel (vor dem Formatieren):

returncode := RP_1Wire_ReadTemp(sensorGroupId := x, sensorId := y, temperature => result);

wird zu (nach dem Formatieren):

	returncode := RP_1Wire_ReadTemp(sensorGroupId := x, sensorId := y, temperature
	=> result);

Abhilfe: nicht vorhanden

2752

Kommentare werden beim Formatieren des Codes nicht zueinander ausgerichtet. Bei einem Kommentar am Anfang der Datei wird eine Leerzeile eingefügt.
Szenario: Falls Sie bereits vorhandenen ST-Code mit dem Befehl Formatieren (im Kontextmenü) bzw. der Tastenkombination Strg+Umschalt+F formatieren, werden Kommentare im ST-Code u.U. nicht zueinander ausgerichtet (siehe Beispiel).
Beispiel (vor dem Formatieren):

FUNCTION_BLOCK FUB_LEDCylon
    /*
     * The LEDs are shifted back and forth.
     */
END_FUNCTION_BLOCK

wird zu (nach dem Formatieren):

FUNCTION_BLOCK FUB_LEDCylon
/*
     * The LEDs are shifted back and forth.
     */
END_FUNCTION_BLOCK

Falls außerdem am Anfang der Datei ein Kommentar vorhanden ist, wird eine Leerzeile vor diesem Kommentar eingefügt. Dadurch beginnt die Datei mit einer Leerzeile.
Abhilfe: nicht vorhanden

2780

Änderungen im ST-Code können Ausnahmesituation beim Laden der Programmierung verursachen
Szenario: Falls Sie das deklarierte Programm im ST-Code löschen, es ist jedoch in einem SPS-Objekt zugeordnet, kann das Laden für die betroffene SPS aus der geöffneten Sicht SPS gestartet werden. In Folge tritt eine Ausnahmesituation in logi.CAD 3 auf.
Abhilfe: Öffnen Sie die Sicht SPS, nachdem Sie die Änderungen im ST-Code gespeichert haben. Da kein korrekter Code aufgrund des gelöschten Programms vorhanden ist, kann das Programm für die SPS nicht erstellt werden: Sie erhalten eine entsprechende Meldung beim Versuch, die Programmierung zu laden.

2783

Interne Fehlermeldung erscheint, falls kein gültiges ST-Objekt vorhanden ist.
Szenario: Falls Sie im ST-Code einen fehlerhafter Aufruf erfassen (siehe Beispiel), erscheinen die Meldungen Konnte die Referenz auf 'Name' nicht auflösen. und die interne Meldung The feature 'variable' of 'URL-Referenz' contains a dangling reference 'URL-Referenz'.
Beispiel:

PROGRAM Template
	VAR
		fbInstance : bool;
	END_VAR
	fbInstance(EN := true);
END_PROGRAM

Abhilfe: Ignorieren Sie die interne Meldung.

2806

"Programm laden" funktioniert nur, falls keine Umlaute im Projektpfad vorhanden sind
Szenario: Wenn Sie die Schaltfläche Programm laden in der Sicht SPS drücken, wird das Programm nur geladen, falls der Projektname keine Umlaute enthält. Beim Erstellen des Projekts werden Umlaute bereits verboten, allerdings können Sie derzeit noch Umlaute beim Umbenennen eines Projekts erfassen.
Abhilfe: Aktualisieren Sie den Inhalt des Projektexplorers (drücken Sie F5) und ändern Sie den Projektnamen wieder, sodass keine Umlaute mehr enthalten sind. Dann können Sie das Programm laden.

2809

Verlinkte Ordner werden beim Exportieren eines Projekts in eine Archivdatei berücksichtigt.
Szenario: Falls Sie ein Projekt in eine Archivdatei exportieren, wird der Inhalt von verlinkten Ordner (z.B. IEC61131-3 mit den IEC-Bausteinen) ebenfalls exportiert. Falls Sie anschließend das Projekt aus der Archivdatei importieren, sind die zuvor verlinkten Ordner zu "eigentlichen" Ordnern im Projekt geworden. In Folge treten möglicherweise Probleme auf, wenn Sie die Objekte verwenden, die im (eigentlich verlinkten) Ordner liegen; z.B. wenn Sie die IEC-Bausteine im ST-Code erfassen.
Abhilfe: Beim Exportieren in eine Archivdatei klappen Sie das zu exportierende Projekt in der linken Liste des Dialogs auf, entfernen Sie die Markierung für die verlinkten Ordner und drücken Sie erst dann Fertigstellen, um den Export zu starten. Nach dem Importieren sind die verlinkten Ordner im Projekt automatisch vorhanden.