Release-Notes für Version 1.0.0

Die Release-Notes für die aktuelle Version finden Sie unter Release-Notes für Version.

Neuigkeiten in Version 1.0.0

IDNeuigkeiten
1169Im ST-Editor können Strukturdatentypen erstellt und in Anwenderbausteinen verwendet werden. Aktuelle Einschränkung: Es werden nur elementare Datentypen für die Strukturelemente unterstützt.
1627

Physikalische Adressen können bei der Deklaration von globalen Variablen zugewiesen werden. Der Zugriff auf die Hardware-IOs für das Beckhoff-Zielsystem CX9020 ist über die globalen Variablen möglich. Hinweis: Die IO-Konfiguration selbst erfolgt im TwinCAT System-Manager von Beckhoff.

2316

Die Sicht SPS informiert durch Symbole in der Spalte Identifikation, ob der Stand der Programmierung, die auf die SPS geladen ist, mit jenem in logi.CAD 3 identisch oder unterschiedlich dazu ist.
Zusätzlich erkennen Sie auch in der Sicht Variablenwerte, dass das Programm auf der SPS nicht mit der aktuellen Programmierung übereinstimmt.

2493

Die Namen aller verfügbarer Plattformen wurden vereinfacht. Der Name nennt jetzt die Ziel-Plattform alleine – vorher enthielt der Name auch das Betriebssystem, unter dem die logi.CAD 3 Projekte erstellt wurden.

Neuer Name

Vorheriger Name

WindowsX86

Win64_Win64

Raspbian

Win64_Raspbian

Ce5Nmr20

Win64_Ce5Nmr20

Durch diese Vereinfachung wird es möglich sein, logi.CAD 3 Projekte, die unter einem Betriebssystem erstellt wurden, ohne Anpassung der eingetragenen Plattform auch unter einem anderen Betriebssystem zu verwenden.
Hinweis: Falls Sie logi.CAD 3 Projekte in früheren Versionen erstellt haben, müssen Sie Ihre Projekte zur weiteren Verwendung so anpassen: Öffnen Sie die SPS-Objekte in allen Projekten. Löschen Sie die dort eingetragene Plattform, dann drücken Sie Strg+Leerzeichen und wählen Sie die gewünschte Plattform aus. Speichern Sie die Änderungen.

Behobene Probleme in Version 1.0.0

IDBehobenes Problem
2409

Keine IEC-konforme Konvertierung von REAL auf ANY_INT
Szenario: Bei der Konvertierung eines REAL-Werts in einen ANY_INT-Wert wird zur nächsten ganzzahligen Zahl auf- oder abgerundet, halbe Anteile (wie z.B.0.5) werden dabei aufgerundet. Diese Rundung der halben Anteile ist nicht IEC-konform, da solche Fälle laut IEC auf die nächste gerade ganzzahlige Zahl zu runden sind.
Behebung: Bei der Konvertierung eines halben REAL-Werts in einen ANY_INT-Wert wird nun konform zur IEC gerundet, und zwar zur nächsten geraden ganzzahligen Zahl. Beispiel: Der REAL-Wert 1.5 und der REAL-Wert 2.5 werden beide zum ANY_INT-Wert 2 konvertiert.

2434

Refactoring eines Bezeichners mit unterschiedlicher Groß-/Kleinschreibung markiert den umbenannten Bezeichner fälschlicherweise als Fehler.
Szenario: Falls Sie mit dem Befehl Element umbenennen (= Refactoring) einen Bezeichner mit unterschiedlicher Groß-/Kleinschreibung (= "Case-Insensitiver" Bezeichner) ändern (siehe Beispiel), werden alle Elemente umbenannt, aber der Bezeichner, für den die Refactoring-Aktion gestartet wurde, wird fälschlicherweise als Fehler im ST-Editor gekennzeichnet.
Beispiel:

PROGRAM Template
	Test();   (* Refactoring-Aktion wird für diesen Bezeichner mit unterschiedlicher Groß-/Kleinschreibung ausgelöst. *)
END_PROGRAM
FUNCTION test : int
END_FUNCTION

Behebung: Umbenannte Bezeichner mit unterschiedlicher Groß-/Kleinschreibung werden nicht mehr fälschlicherweise als Fehler markiert.

2463

Bereits vorhandenes Projekt für Raspberry Pi und für Beckhoff CX9020 wird nicht erkannt.
Szenario: Falls Sie ein neues Projekt für Raspberry Pi oder für Beckhoff CX9020 erstellen und es existiert bereits ein Projekt mit diesem Namen im Arbeitsbereich, wird ein neues Projekt erstellt, das nicht verwendbar ist.
Behebung: logi.CAD 3 informiert Sie, falls Sie ein Projekt mit einem Namen erstellen wollen, das bereits existiert. Die Ausführung ist nicht mehr möglich.

2466

Sicht "SPS" zeigt Text "Ressource", aber Symbole für Konfiguration
Szenario: Die Sicht SPS zeigt den Text Ressourcen als Spaltenüberschrift. Es werden jedoch die Symbole für Konfigurationen angezeigt, wie diese aus logi.CAD/32 bekannt sind. Andere Sichten zeigen ebenfalls diese Symbole für Konfigurationen, wo jedoch die Ressourcen laut IEC gemeint sind.
Behebung: Die Spaltenüberschrift IEC-Ressource wird in der Sicht angezeigt. Außerdem werden andere Symbole in den Sichten angezeigt.

2481

Keine Kennzeichnung als Fehler, falls eine Funktionsbaustein-Instanz als Bedingung in einer IF-Anweisung erfasst wird.
Szenario: Falls Sie eine Funktionsbaustein-Instanz als Bedingung in einer IF-Anweisung erfassen, wird diese Funktionsbaustein-Instanz nicht als fehlerhafter Ausdruck gekennzeichnet.
Beispiel:

PROGRAM Template
   VAR Instance : FBTest; END_VAR
   if Instance = 1 then 
      (* 'Instance' ist nicht erlaubt, wird aber nicht als Fehler markiert. *)
      A := 5;
   end_if;
END_PROGRAM
FUNCTION_BLOCK FBTest END_FUNCTION_BLOCK

Behebung: Eine Funktionsbaustein-Instanz, die als Bedingung in einer IF-Anweisung erfasst ist, wird als Fehler markiert.

2484

Keine Kennzeichnung als Fehler, falls eine Funktion als Bedingung in einer IF-Anweisung erfasst wird und dieser Funktion ist nicht ein Ergebniswert zugewiesen.
Szenario: Falls Sie eine Funktion als Bedingung in einer IF-Anweisung erfassen und dieser Funktion ist kein Ergebniswert zugewiesen, wird diese Funktion nicht als fehlerhafter Ausdruck gekennzeichnet.

Beispiel
PROGRAM Template
   if FunTest() = 1 then
      (* 'FunTest() = 1' ist nicht erlaubt, wird aber wird nicht als Fehler markiert. *)
      A := 5;
   end_if;
END_PROGRAM
FUNCTION FunTest
END_FUNCTION

Behebung: Eine Funktion ohne zugewiesenen Ergebnistyp, die als Bedingung in einer IF-Anweisung erfasst ist, wird als Fehler markiert.

Bekannte Probleme in Version 1.0.0

ID

Bekanntes Problem

1551

Befehle zum Zurücksetzen/Wiederherstellen der ersten/letzten Zeile zeigen keine korrekte oder gar keine Funktionalität (betrifft die Schnelldifferenz)
Szenario: Wenn die Schnelldifferenz aktiviert ist (gewählter Befehl Schnelldifferenz anzeigen) und Sie die erste oder letzte Zeile des ST-Codes geändert/gelöscht haben, funktionieren die Befehle zum Zurücksetzen/Wiederherstellen der entsprechenden Zeile (z.B. Gelöschte Zeile wiederherstellen) nicht korrekt bzw. gar nicht. Diese Befehle sind im Kontextmenü für den Rand links vom Code bei den gezeigten Schnelldifferenz-Einträgen zu finden.
Abhilfe: Im Kontextmenü des ST-Editors wählen Sie Datei zurücksetzen (damit verwerfen Sie alle Änderungen seit dem letzten Speichern) oder wählen Sie Rückgängig sooft, bis wieder der ursprüngliche Code in der ersten bzw. letzten Zeile angezeigt wird.

1795

Befehl "Öffnen mit", "Direkt angezeigter Editor" nicht erfolgreich
Szenario: Wenn Sie im Kontextmenü des Projektexplorers den Befehl Öffnen mit und Direkt angezeigter Editor wählen (z.B. für ein ST-Objekt), wird folgende Meldung angezeigt: Wiederherstellen des direkten Editors nicht möglich. Direktunterstützung fehlt
Abhilfe: Verwenden Sie den Befehl Öffnen mit und ST-Editor, um ST-Objekte und SPS-Objekte zu öffnen. Für andere Objekte, wie z.B. Textdateien, können Sie den Befehl Öffnen mit und Texteditor verwenden.

1843

Englischer Text "Whole word" im Dialog "Suchen"
Szenario: In der deutschen Sprachversion enthält der Dialog Suchen die Option Whole word (englische Bezeichnung für "Ganzes Wort").

1844

"Umbenennen" und "Löschen" im Projektexplorer möglich, wenn keine Ressourcen selektiert sind
Szenario: Wenn im Projektexplorer keine Ressourcen selektiert sind, können Sie die Befehle Umbenennen bzw. Löschen aufrufen (aus dem Menü Datei bzw. Bearbeiten und via Tastenkombination F2 bzw. Entf), obwohl diese keine sinnvolle Funktionalität haben.
Abhilfe: Selektieren Sie zumindest eine Ressource im Projektexplorer, bevor Sie den Befehl aufrufen.

1910

"Anzeigen in (Instanzen)" in Schnellzugriff verursacht Fehler
Szenario: Falls Sie einen Editor geöffnet haben und den Befehl Anzeigen in (Instanzen) im Feld für Schnellzugriff eingeben/auswählen, tritt ein Fehler auf.
Abhilfe: nicht vorhanden

1920

Fehlermeldung beim Umbenennen von Projekten, die nicht im Arbeitsbereich liegen
Szenario: Wenn Sie ein Projekt außerhalb des Arbeitsbereichs erstellt haben und dieses anschließend umbenennen, werden interne Fehler angezeigt, dass die Datei .project (im Arbeitsbereich) für das Projekt nicht vorhanden ist. Das Umbenennen selbst hat jedoch scheinbar funktioniert.
Abhilfe: Ignorieren Sie den internen Fehler (wie in der Benutzerdokumentation unter "Projekt umbenennen" dokumentiert).

2470

Sichten "SPS", "Instanzen" und "Variablenwerte" unterstützen einige Tastenkombinationen nicht
Szenario: Folgende Tastenkombinationen haben keine Funktion in den Sichten SPS, Instanzen und Variablenwerte.

Tastenkombination

Funktion

Alt+-

System-Menü der Sicht anzeigen

F12

von Sicht zum aktuellen Editor wechseln

Strg+F7

nächste Sicht

Strg+Umschalt+F7

vorherige Sicht

Strg+F10

Menü für Sicht anzeigen

Strg+M

aktuelle Sicht zwischen maximiertem und wiederhergestelltem Zustand umschalten

Abhilfe: Verwenden Sie die Maus, um die gewünschte Funktion in den genannten Sichten auszulösen.

2473

Bestimmte Tastenkombinationen in Sichten "SPS", "Instanzen" und "Variablenwerte" zeigen die Auswahlliste immer auf dem Hauptbildschirm.
Szenario: Wenn Sie in den Sichten SPS, Instanzen und Variablenwerte die folgenden Tastenkombinationen drücken, erscheint eine Auswahlliste. Diese Auswahlliste erscheint immer auf dem Hauptbildschirm, auch wenn logi.CAD 3 auf dem 2. Bildschirm angezeigt wird.

Tastenkombination

Funktion

Strg+F6

nächster Editor

Strg+Umschalt+F6

vorheriger Editor

Strg+F8

nächste Perspektive

Strg+Umschalt+F8

vorherige Perspektive

Abhilfe: Verwenden Sie die entsprechenden Befehle im Menü Fenster, um die gewünschte Funktion in den genannten Sichten auszulösen.

2602

"Programm laden" funktioniert nur, falls keine Umlaute im Projektpfad vorhanden sind
Szenario: Wenn Sie die Schaltfläche Programm laden in der Sicht SPS drücken, wird das Programm nur geladen, falls das Projekt in einem Verzeichnis ohne Umlaute erstellt wurde.
Abhilfe: Ändern Sie den Teils des Projektpfads, sodass keine Umlaute mehr enthalten sind. Dann können Sie das Programm laden.

2612

Inhaltshilfe enthält EN bzw. ENO für Funktionen zur Auswahl, obwohl diese in diesem Kontext nicht erlaubt sind.
Szenario: Wenn Sie die Inhaltshilfe außerhalb eines Funktionsaufrufs verwenden, wird der Eingang EN bzw. der Ausgang ENO zur Auswahl angeboten. Die Verwendung von EN bzw. ENO ist jedoch nur im Funktionsaufruf erlaubt.
Abhilfe: Wählen Sie den Eingang EN bzw. den Ausgang ENO nur, wenn Sie sich in einem Funktionsaufruf befinden.

2622

"Programm laden" für Raspberry-Pi- und Beckhoff-CX9020-Projekte funktioniert nur, falls keine Leerzeichen im Namen des Installationsverzeichnis vorhanden
Szenario: Wenn Sie die Schaltfläche Programm laden in der Sicht SPS drücken, wird das Programm eines Raspberry-Pi- bzw. Beckhoff-CX9020-Projekts nur geladen, falls logi.CAD 3 in ein Verzeichnis ohne Leerzeichen installiert wurde.
Abhilfe: Ändern Sie den Namen des Installationsverzeichnis, sodass er keine Leerzeichen enthält.

2630

Inhaltshilfe in SPS-Objekt bietet Liste der Plattformen nicht, wenn bereits Buchstaben erfasst sind.
Szenario: Wenn Sie die Inhaltshilfe zum Erfassen einer Plattform innerhalb eines SPS-Objekts verwenden und Sie haben Buchstaben im Editor erfasst (zur Einschränkung der Elemente, die die Inhaltshilfe anbietet), werden die möglichen Plattformen nicht angeboten.

Beispiel
	RESOURCE local ON R (* Nach 'R' sollte die Inhaltshilfe die Liste der Plattformen anbieten. *)

Abhilfe: Erfassen Sie keine Buchstaben (wie z.B. R), sondern drücken Sie sofort Strg+Leerzeichen (= öffnet an dieser Stelle die Liste mit den möglichen Plattformen).

2634

Flackernde Sicht "SPS" (bei Aktualisierungen des SPS-Objekts)
Szenario: Falls das SPS-Objekt bearbeitet wird, ist eine flackernde Anzeige der Sicht SPS möglich. Genauere Ursachen für dieses Problem sind derzeit nicht bekannt.
Abhilfe: Bearbeiten Sie das SPS-Objekt in der Perspektive Applikationserstellung (ohne der Sicht SPS). Danach speichern Sie das geänderte SPS-Objekt und öffnen die Perspektive Applikationstest (mit der Sicht SPS).

2637

Ein Projekt mit einem Konvertierungsbaustein kann nicht auf einen Raspberry Pi geladen werden.
Szenario: Falls Sie einen Konvertierungsbaustein (z.B. TO_INT) im ST-Code verwenden, ist es nicht möglich, das Programm auf einen Raspberry Pi zu laden.
Abhilfe: Kontaktieren Sie den Support von logi.cals für einen Hotfix.

2640

Die Systembausteine können im Projektexplorer gelöscht werden.
Szenario: Wenn im Projektexplorer ein Systembaustein selektiert ist (z.B. der RS-Baustein), können Sie den Befehl Löschen aufrufen (aus dem Menü Bearbeiten und via Tastenkombination Entf). In Folge ist der Systembausteine nicht mehr verfügbar.
Abhilfe: Installieren Sie logi.CAD 3 erneut. In Folge ist der Systembaustein wieder verfügbar.

2643

Fehlermeldung Error Executing EValidator erscheint, falls kein gültiges ST-Objekt vorhanden ist.
Szenario: Wenn Sie bei einer Zuweisung im ST-Code den Namen einer Variable erfassen, für die keine Deklaration vorhanden ist, erscheinen die Meldungen Konnte die Referenz auf 'Name' nicht auflösen. und die interne Meldung Error executing EValidator.
Abhilfe: Ignorieren Sie die interne Meldung Error executing EValidator.

2653

Fehlermeldung First position: 'NAME' at xx, this position: 'NAme' at yy erscheint beim Refactoring eines Bezeichners mit unterschiedlicher Groß-/Kleinschreibung im gleichen ST-Objekt.
Szenario: Falls Sie mit dem Befehl Element umbenennen (= Refactoring) einen Bezeichner mit unterschiedlicher Groß-/Kleinschreibung (= "Case-Insensitiver" Bezeichner) ändern (siehe Beispiel) und alle Elemente befinden sich im gleichen ST-Objekt, wird fälschlicherweise der Fehler First position: 'NAME' at xx, this position: 'NAme' at yy in der Sicht Fehlerprotokoll angezeigt. Die Refactoring-Aktion selbst wird korrekt durchgeführt.
Beispiel:

PROGRAM Template
	Test();   (* Refactoring-Aktion wird für diesen Bezeichner mit unterschiedlicher Groß-/Kleinschreibung ausgelöst. *)
END_PROGRAM
FUNCTION test : int
END_FUNCTION

Abhilfe: Ignorieren Sie die angezeigte Meldung.

2657

Physikalische Adressen in Deklaration von globalen Variablen ändern nicht die Identifikation (den Fingerprint) der IEC-Ressource in Sicht "SPS"
Szenario: Wenn Sie ST-Code ändern und speichern, zeigt die Sicht SPS in der Spalte Identifikation einen geänderten Fingerprint für die IEC-Ressource. Dadurch können Sie erkennen, dass der Stand der Programmierung, die auf die SPS geladen ist, unterschiedlich zu jenem in logi.CAD 3 ist. Falls Sie nur physikalische Adressen bei der bereits vorhandenen Deklaration von globalen Variablen erfassen, löschen oder ändern, fließen diese Modifikationen nicht in die Berechung des Fingerprints ein. Das bedeutet, dass der Stand irrtümlich als identisch gekennzeichnet wird.
Abhilfe: Erfassen Sie physikalischen Adressen immer gleichzeitig mit der Deklaration der globalen Variablen. Bei Änderung von physikalischen Adressen (ohne anderer code-relevanten Änderungen) laden Sie das Programm immer erneut auf die SPS.