The Windows Firewall has blocked features of this program.

Symptoms:

  • When starting logi.CAD 3, Windows security alerts The Windows Firewall has blocked some features of this program appear.

or

  • Error messages are displayed when loading the application, such as Timeout during execution of a target command.

Causes:

  • The Windows firewall is enabled.
  • All connections are blocked or there are no rules that allow the connection of logi.CAD 3 to the built-in PLC or a remote →PLC (= remote target system).

Solutions: Define the following rules for the Windows firewall (or ask your administrator to do so):

Rule typeDefinitionsAction
Port – rule controlling the connection for a TCP or UDP portTCP, port 1535Allow the connection
Port – rule controlling the connection for a TCP or UDP portUDP, port 1535Allow the connection
Port – rule controlling the connection for a TCP or UDP port

TCP, port 1883  (1)

Allow the connection
Port – rule controlling the connection for a TCP or UDP portUDP, port 2048Allow the connection
Program – rule controlling the connection for a program

Install-path\logiCAD3.exe
Example: c:\logi.cals\logiCAD3.exe

Allow the connection

(1) By default, the TCP port 1883 is used by the MQTT broker that is required for transferring data via MQTT. If you use a different TCP port for the MQTT broker, allow the connection for this different port.Alternate solution (only applicable, if there are not error messages when loading the application): Click Allow access for the Windows security alert.
If you are using only the built-in PLC for logi.CAD 3, you can click Cancel as well. The built-in PLC is automatically started and you can use it in logi.CAD 3 anyway. However, in order to address remote PLCs it will be necessary to adjust the existing firewall rules as mentioned above.

(info) logi.cals recommends to install and use the most current versions of logi.CAD 3 and the runtime system so that the latest features and problem fixes according to the release notes are provided in the used version. 


Did this article help you? Did you find the requested information in this user documentation?
If not, contact the support team of logi.cals. State your questions or suggestions to improve/enhance the user documentation as detailed as possible.