Release-Notes für Versionen vor 1.0.0

Die Release-Notes für die aktuelle Version finden Sie unter Release-Notes für Version.

Release-Notes für Version 0.16.0

Neuigkeiten in Version 0.16.0

IDNeuigkeiten
1240

Im ST-Editor können komplexe Ausdrücke verwendet werden. Ein Ausdruck ist ein Sprachkonstrukt, das aus einer Kombination von Operanden (z.B. Literale, Variablen, Aufrufe) und Operatoren (z.B. +, -, *, /) besteht und einen Wert eines bestimmten Datentyps ergibt.

1269

Während der Abarbeitung des Automatisierungsprogramms auf der aktiven SPS können Werte von Variablen nacheinander geändert werden: Der neue Wert wird umgehend auf die SPS geschrieben.

1634

Neue Projekte für das Beckhoff-Zielsystem "CX9020" können aufgrund der neuen Vorlage logi.CAD 3 Projekt für Beckhoff CX9020 erstellt werden. Solche ein Projekt enthält das SPS-Objekt remote mit Standardwerten für das Laden eines einfachen Programmes auf eine CX9020. Bei der Programmierung können die angebotenen Bausteine aus der Standardbibliothek IEC61131-3 verwendet werden.

Behobene Probleme in Version 0.16.0

IDBehobenes Problem
2304

"Programm laden" verursacht Terminierung von logi.RTS, falls das geladene Programm einen MOD-Operator enthält und dabei wird eine Division durch 0 durchgeführt.
Szenario: Wenn Sie die Schaltfläche Programm laden in der Sicht SPS drücken und das Programm (bzw. darin verwendete Funktionsbausteine bzw. Funktionen) enthält einen MOD-Operator, bei dem eine Division durch 0 durchgeführt wird, terminiert logi.RTS
Abhilfe: nicht vorhanden
Behebung: logi.CAD 3 prüft bei der Ausführung auf eine Division durch 0 und liefert 0 als Ergebnis.

2307

TIME-Werte nur bis T#106751d in Sicht "Variablenwerte" darstellbar
Szenario: Wenn Sie sich in der Sicht Variablenwerte über den aktuellen Werte von Variablen auf der SPS informieren, werden TIME-Werte nur bis T#106751d dargestellt. TIME-Werte darüber hinaus werden nicht dargestellt.
Abhilfe: nicht vorhanden
Behebung: Es sind TIME-Werte bis T#89_468_321d19h42m34s400ms in Sicht "Variablenwerte" darstellbar.

2324

Refactoring eines Funktionsbezeichners berücksichtigt zugewiesenen Ergebniswert innerhalb der Funktion nicht
Szenario: Falls Sie mit dem Befehl Element umbenennen den Bezeichner einer Funktion ändern (= Refactoring), berücksichtigt diese Refactoring-Aktion nicht evtl. zugewiesene Ergebniswerte innerhalb der Funktion.
Beispiel:

FUNCTION Simple : INT (* Funktion mit umbenannten Bezeichner *)
  VAR
    var1 : INT;
  END_VAR
  Test := 1; (* zugewiesener Ergebniswert, für den der Bezeichner aber nicht umbenannt wurde *)
END_FUNCTION

Abhilfe: nicht vorhanden
Behebung: Die Refactoring-Aktion berücksichtigt evtl. zugewiesene Ergebniswerte innerhalb der Funktion.

2327

Änderungen im Programm können Ausnahmesituation in Sicht "Variablenwerte" verursachen
Szenario: Wenn Sie sich in der Sicht Variablenwerte über aktuelle Werte von Variablen auf der SPS informieren, parallel dazu den ST-Code ändern und danach auf die ursprüngliche Variable in der Sicht doppelklicken, kann eine Ausnahmsituation in logi.CAD 3 ausgelöst werden.
Abhilfe: Ändern Sie nicht die Logik, während Sie Variablen in der Sicht Variablenwerte beobachten.
Behebung: Nach dem Doppelklicken auf die Variable informiert Sie eine Meldung, falls die Programmierung geändert, aber nicht hochgeladen wurde.

2335

Fehlender Funktionsbezeichner verursacht Ausnahmesituation
Szenario: Falls Sie im erfassten Code keinen Bezeichner bei der Deklaration einer Funktion erfassen (siehe Beispiel), wird eine Ausnahmsituation in logi.CAD 3 ausgelöst.
Beispiel:

function
end_function

Abhilfe: Erfassen Sie bei Deklarationen immer einen Bezeichner.
Behebung: Fehlende Funktionsbezeichner werden als Fehler in logi.CAD 3 gekennzeichnet.

2338

Globale Variablen werden nicht korrekt initialisiert
Szenario: Falls Sie globale Variablen initialisieren, werden diese auf der SPS nicht mit dem erfassten Wert initialisiert.
Abhilfe: nicht vorhanden
Behebung: Globale Variablen werden auf der SPS korrekt initialisiert.

2365

Bei unterschiedlichen SPS-Objekten mit gleichen Namen nach RESOURCE werden nicht benötigte Dateien geladen.
Szenario: Falls Sie gleiche Namen nach RESOURCE in unterschiedlichen SPS-Objekten erfassen, speichert logi.CAD 3 den ST-Code, der beim Laden benötigt wird, in den gleichen Ordner. Wenn Sie anschließend das Programm für eine SPS laden, werden dabei auch die Programmteile der anderen SPS geladen.
Abhilfe: Erfassen Sie eindeutige Namen nach RESOURCE.
Behebung: Sie können gleiche Namen nach RESOURCE in unterschiedlichen SPS-Objekten erfassen. Beim Laden des entsprechenden Programms werden nur die Programmteile der aktuellen SPS geladen.

2369

TIME-Werte werden ungenau auf SPS abgebildet bzw. Microsekunden-Angaben (us) und Nanosekunden-Angaben (ns) in TIME-Werten werden nicht von logi.RTS verarbeitet
Szenario 1: Wenn Sie Zeitdauer-Literale erfassen (z.B. T#49710d6h28m15s in Zuweisungen), werden diese ungenau auf der SPS abgebildet.
Szenario 2: Wenn Sie Zeitdauer-Literale mit kleineren Einheiten als Millisekunden erfassen (z.B. t#12h4m34ms230us400ns), werden die Einheiten für Microsekunden (us) und Nanosekunden (ns) von logi.RTS nicht verarbeitet. Bezogen auf das Beispiel wird in Folge {{t#12h4m34ms} in der Sicht Variablenwerte dargestellt.
Abhilfe: nicht vorhanden
Behebung: Zeitdauer-Literale werden korrekt auf der SPS abgebildet, sofern diese innerhalb der entsprechenden Timer-Frequenz liegen, die für die SPS gilt. So werden Zeitdauer-Literale mit Einheiten bis zu 100 Mikrosekunden von logi.RTS (für Windows) verarbeitet, kleinere Angaben werden nicht verarbeitet. Bezogen auf das Beispiel t#12h4m34ms230us400ns wird daher t#12h4m34ms200us in der Sicht Variablenwerte dargestellt.

Release-Notes für Version 0.15.0

Neuigkeiten in Version 0.15.0

IDNeuigkeiten
599
Das auf ein Zielsystem geladene Programm kann getestet werden. Für den Test aktiviert logi.CAD 3 eine spezielle Test-Perspektive, in der Sie die aktuellen Werte der Variablen auf dem Zielsystem beobachten können.
778

Im ST-Editor kann der IEC-61131-3-Systembaustein AND mit folgenden Datentypen beschaltet werden: BOOL, BYTE, WORD, DWORD, LWORD
Im ST-Editor können die IEC-61131-3-Systembausteine ADD, MUL, SUB, DIV, LT und GT mit folgenden Datentypen beschaltet werden: REAL, USINT, UINT, UDINT, ULINT, SINT, INT, DINT, LINT

1596

Neue Projekte für das Zielsystem "Raspberry Pi" können mit Hilfe der neuen Vorlage logi.CAD 3 Projekt für Raspberry PI erstellt werden. Solch ein Projekt enthält das SPS-Objekt remote mit Standardwerten für das Laden eines einfachen Programmes auf einen Raspberry Pi. Bei der Programmierung können die angebotenen Bausteine aus der Standardbibliothek Raspberry Pi verwendet werden.

Behobene Probleme in Version 0.15.0

IDBehobenes Problem
2122

Alt+Umschalt+ N öffnet Menü "Navigieren" (statt Optionen zum Erstellen von neuen Ressourcen anzubieten)
Szenario: Wenn Sie die Tastenkombination Alt+Umschalt+ N drücken, wird das Menü Navigieren angezeigt. logi.CAD 3 führt die Tastenkombination jedoch für den Befehl Neu (im Menü Datei) an, mit dem Sie Optionen zum Erstellen von neuen Ressourcen erhalten.
Abhilfe: Falls Sie neue Ressourcen erstellen wollen, verwenden Sie den Befehl Neu (im Menü Datei) oder die Tastenkombination Strg+N (öffnet den Assistenten).
Behebung: Die Tastenkombination Alt+Umschalt+ N zeigt die Optionen zum Erstellen von neuen Ressourcen.

2135

Änderungen am Layout werden für den gewechselten Arbeitsbereich übernommen
Szenario: Änderungen am Layout von logi.CAD 3 werden automatisch im aktiven Arbeitsbereich von logi.CAD 3 gespeichert (z.B. eine zusätzliche Sicht öffnen, weitere Projekte im Projektexplorer erstellen/importieren). Falls Sie zu einem anderen Arbeitsbereich wechseln (Befehl Arbeitsbereich wechseln... im Menü Datei), übernimmt logi.CAD 3 die Änderungen auch für den anderen Arbeitsbereich, statt das Layout des anderen Arbeitsbereichs zu aktiveren.
Abhilfe: nicht vorhanden; logi.cals empfiehlt Ihnen, den Befehl Arbeitsbereich wechseln... derzeit nicht zu verwenden.
Behebung: Die Änderungen am Layout werden beim Wechseln des Arbeitsbereichs übernommen. Bedingung: logi.CAD 3 wurde vor dem Wechseln geschlossen und erneut gestartet.

2181

Zyklische Verweise werden nicht als Fehler gekennzeichnet.
Szenario: Falls Sie im ST-Editor zyklische Verweise erstellen (z.B. Aufruf der aktuellen Funktionsbaustein-Instanz; siehe Beispiel), wird der zyklische Verweis nicht als Fehler gekennzeichnet. Beim Speichern von Code mit zyklischen Verweisen für Funktionsbaustein-Instanzen erscheint ein "StackOverflow"-Fehler.
Beispiel:

PROGRAM Template VAR fb1 : MyFB; END_VAR END_PROGRAM
FUNCTION_BLOCK MyFB
	VAR
		fb1 : MyFB;  (* cyclic reference *)
	END_VAR	
END_FUNCTION_BLOCK

Abhilfe: nicht vorhanden; Vermeiden Sie solche zyklischen Verweise derzeit.
Behebung: Die Meldung Rekursive Verwendung von Funktionsbausteinen ist nicht erlaubt. wird ausgegeben.

Release-Notes für Version 0.14.0

Neuigkeiten in Version 0.14.0

IDNeuigkeiten
778

Im ST-Editor kann der IEC-61131-3-Systembaustein AND mit folgenden Datentypen beschaltet werden: BOOL, BYTE, WORD, DWORD, LWORD
Im ST-Editor können die IEC-61131-3-Systembausteine ADD, MUL, SUB, DIV, LT und GT mit folgenden Datentypen beschaltet werden: REAL, USINT, UINT, UDINT, ULINT, SINT, INT, DINT, LINT

1233

Im ST-Editor können FOR-Anweisungen (inkl. deren Schlüsselwörter, wie z.B. TO) erfasst werden. Mit der FOR-Anweisung bestimmen Sie, dass eine Gruppe von Anweisungen wiederholt ausgeführt wird, während eine Reihe von Werten der FOR-Steuervariable zugeordnet wird.

1277

Im ST-Editor können REPEAT-Anweisungen (inkl. deren Schlüsselwörter, wie z.B. UNTIL) erfasst werden. Mit der REPEAT-Anweisung bestimmen Sie, dass eine Gruppe von Anweisungen wiederholt (zumindest einmal) ausgeführt wird, bis der mit dem Schlüsselwort UNTIL verknüpfte Boolesche Ausdruck mit Wert TRUE ausgewertet wird. Für die Bedingung wird derzeit nur genau ein Boolescher Bezeichner unterstützt (entweder eine Boolesche Variable oder einen Aufruf einer Funktion, die einen Booleschen Wert liefert).

Behobene Probleme in Version 0.14.0

IDBehobenes Problem
2028

Deklaration als fehlerhaft markiert, falls Initialisierung von Variablen fehlerhaft
Szenario: Falls Sie Variablen falsch initialisieren (z.B. einen Sonderzeichen als Initialisierungswert oder gar keinen Initialisierungswert angeben), wird die Deklaration der darüber liegenden POE als fehlerhaft markiert, anstatt der Zeile mit dem falschen oder fehlenden Initialisierungswert. Als Meldung wird Unerwartetes Zeichen ';' in der Sicht Fehler angezeigt.
Beispiel:

FUNCTION test               (* This line is highlighted as faulty. *)
   VAR
      var1 : BOOL :=;       (* However, this line is faulty as there is no initial value. *)
   END_VAR
END_FUNCTION

Behebung: Die Zeile mit dem falschen oder fehlenden Initialisierungswert wird als fehlerhaft markiert.

Release-Notes für Version 0.13.0

Neuigkeiten in Version 0.13.0

ID

Neuigkeiten

1101Im ST-Editor können globale Variablen innerhalb eines Programms deklariert werden. Sofern Sie Funktionsbausteine und/oder Funktionen im Programm verwenden, können Sie die globalen Variablen in diesen Funktionsbausteinen und/oder Funktionen als externe Variablen referenzieren und verwenden.
1155

Im ST-Editor können IF-Anweisungen (inkl. deren Schlüsselwörter, wie z.B. ELSE) erfasst werden. Mit der IF-Anweisung bestimmen Sie, dass eine Gruppe von Anweisungen nur dann ausgeführt wird, falls die damit verknüpfte Bedingung mit Wert TRUE ausgewertet wird. Für die Bedingung wird derzeit nur genau ein Boolescher Bezeichner unterstützt (entweder eine Boolesche Variable oder einen Aufruf einer Funktion, die einen Booleschen Wert liefert).

1162

Im ST-Editor können WHILE-Anweisungen (inkl. deren Schlüsselwörter, wie z.B. DO) erfasst werden. Mit der WHILE-Anweisung bestimmen Sie, dass eine Gruppe von Anweisungen wiederholt ausgeführt wird, bis der damit verknüpfte Boolesche Ausdruck mit Wert FALSE ausgewertet wird. Für die Bedingung wird derzeit nur genau ein Boolescher Bezeichner unterstützt (entweder eine Boolesche Variable oder einen Aufruf einer Funktion, die einen Booleschen Wert liefert).

1177

Im ST-Editor können Variablen bei ihrer Deklaration initialisiert werden. Derzeit können Sie boolesche Literale, Integer-Literale, Real-Literale und Zeitdauer-Literale für den Initialisierungswert erfassen. Beispiel für Deklaration einer Variable mit Initialisierung: VAR var1 : DINT := 4711; END_VAR

1589

Im ST-Editor können Bausteine aus einer Raspberry-Pi-Bibliothek für die Ansteuerung analoger und/oder digitaler Ein-/Ausgänge und für die serielle Kommunikation verwendet werden. Die Bibliothek und deren Bausteine stehen im Projektexplorer für alle geöffneten Projekte zur Verfügung.

Behobene Probleme in Version 0.13.0

ID

Behobenes Problem

1874

Nicht alle Konstrukte sind für Zuweisung bei EN im formalen Aufruf möglich
Szenario: Wenn Sie in einem formalen Aufruf den EN-Eingang beschalten wollen, können Sie dafür nur Variablen und boolesche Literale verwenden, aber keine Aufrufe einer Funktion und keine Ausgangsvariablen einer Funktionsbaustein-Instanz.
Beispiel:

myFun(EN:=FALSE, I1:=8, I2:=9);  (* this is possible *)
myFun(EN:=NOT(FALSE), I1:=8, I2:=9);     (* this is not possible *)

Behebung: Die oben genannte Konstrukte für EN werden in einem formalen Aufruf unterstützt.

Release-Notes für Version 0.12.1

Neuigkeiten in Version 0.12.1

ID

Neuigkeiten

745

logi.CAD 3 bietet eine benutzerfreundlichere Bedienung folgende Punkte betreffend:

  • Aktionen im Projektexplorer können auch mit Tastenkombinationen ausgelöst werden (z.B. Strg+C für Ressourcen kopieren).
  • Sichten (z.B. Projektexplorer oder Fehler) und der Schnellzugriff können durch Befehle im Menü Fenster eingeblendet bzw. angesprungen werden.
  • Das Menü SPS bietet Befehle sowohl zum Laden des Programms auf die SPS als auch zum Starten und Stoppen des geladenen Programms. Der bisherige Befehl Programm laden... wurde auf Status anzeigen geändert (damit wird die Sicht SPS mit den Status-Informationen der SPS geöffnet).
913

logi.CAD 3 bietet eine Sicht auf die Instanzstruktur eines Projekts. Doppelklicken auf ein angezeigtes Element bringt Sie zur entsprechenden Deklaration der POE (im ST-Editor).

1836

Im ST-Editor können folgende IEC-61131-3-Systembausteine verwendet werden (teilweise jedoch als eingeschränkte Variante):
AND mit 16 BOOL-Eingängen, EQ mit 16 REAL-Eingängen, OR mit 16 BOOL-Eingängen, XOR mit 16 BOOL-Eingängen, MUL_TIME als REAL-Variante, LT mit 16 REAL-Eingängen, GT mit 16 REAL-Eingängen, DIV als REAL-Variante, MUL mit 16 REAL-Eingängen, R_TRIG, RS, CTU, CTD und TOF

Behobene Probleme in Version 0.12.1

ID

Behobenes Problem

1778

Fehler im nicht-formalen Aufruf wird nicht für ST-Editor berücksichtigt (nach Änderung)
Szenario: Wenn Sie zu viele Parameter bei einem nicht-formalen Aufruf erfassen, wird der Fehler im ST-Editor gekennzeichnet und nach dem Speichern erscheint eine Meldung in der Sicht Fehler. Falls Sie den Aufruf korrigieren, aber er weiterhin fehlerhaft ist, wird der Fehler nach dem Speichern korrekt in der Sicht Fehler gemeldet, aber im ST-Editor wird der Aufruf fälschlicherweise nicht mehr als Fehler gekennzeichnet.
Beispiel: Der nicht-formale Aufruf AND(true,false,false) ist fehlerhaft, da derzeit nur 2 Eingänge für den AND-Baustein unterstützt werden. Wird er auf AND(true,false,true) geändert, wird der Aufruf nicht mehr als Fehler im ST-Editor gekennzeichnet, obwohl der Aufruf nicht korrekt ist.
Behebung: Das Problem tritt nicht mehr auf – nach dem Speichern wird ein korrigierter, aber fehlerhafter Aufruf weiterhin als Fehler gekennzeichnet.

1802

"Programm laden" erfolgreich - Fehlermeldung wird fäschlicherweise angezeigt
Szenario: Wenn Sie die Schaltfläche Programm laden in der Sicht SPS drücken, ist es möglich, dass das Programm erfolgreich geladen wurde, aber die folgende Meldung fäschlicherweise angezeigt wird: Allgemeiner Fehler bei der Ausführung eines Zielsystem-Kommandos. Die Meldung kann aber auch angezeigt werden, falls das Programm tatsächlich nicht erfolgreich geladen wurde.
So kontrollieren Sie, dass das Programm erfolgreich geladen wurde: Prüfen Sie in der Sicht SPS die angezeigten Informationen in der Tabelle unter Informationen zur SPS. Falls das Datum bzw. die Zeit in Zeile Am/um einen neuen Wert anzeigen, wurde das Programm trotz der Meldung geladen.
Behebung: Das Problem tritt nicht mehr auf – die Meldung wird nur mehr angezeigt, falls das Programm nicht erfolgreich geladen wurde.

1805

"Programm laden" funktioniert nicht, falls Aufruf der Funktion ohne Parameterliste vorhanden, aber die aufgerufene Funktion enthält Eingangsvariablen
Szenario: Beim Drücken auf die Schaltfläche Programm laden in der Sicht SPS wird das Programm nicht geladen, falls das Programm (bzw. darin verwendete Funktionsbausteine) Aufrufe von Funktionen ohne Parameterliste enthält, aber die aufgerufene Funktion enthält Eingangsvariablen.

Beispiel
FUNCTION emptyFunction
   emptyBodyFunctionI();
END_FUNCTION
FUNCTION emptyBodyFunctionI
  VAR_INPUT in1 : bool; END_VAR
END_FUNCTION

Abhilfe: Definieren Sie die bestehenden Eingänge als Parameter beim Aufruf der Funktion.

Beispiel
FUNCTION emptyFunction
  emptyBodyFunctionI(in1:=TRUE);
END_FUNCTION
FUNCTION emptyBodyFunctionI
	VAR_INPUT in1 : bool; END_VAR
END_FUNCTION

Behebung: Das Problem tritt nicht mehr auf – der Aufruf der Funktion ohne Parameterliste ist möglich.

1820

Fehlerhafte Zuweisung nicht erkannt, falls Ausdruck auf der rechten Seite ein Aufruf einer Funktion ist und diese Funktion keinen Ergebniswert hat
Szenario: Falls Sie eine Zuweisung erfassen und der Ausdruck auf der rechten Seite der Zuweisung ist ein Aufruf einer Funktion, muss ein Ergebniswert für diese Funktion deklariert sein. Ist das nicht der Fall, kann die Programmierung nicht geladen werden. Derzeit wird die fehlerhafte Zuweisung im ST-Editor nicht gemeldet.
Beispiel:

PROGRAM Test
  VAR RC:INT; END_VAR
  RC:=call();   (* Diese Zuweisung ist fehlerhaft, wird aber nicht als Fehler gekennzeichnet. *)
END_PROGRAM
FUNCTION call
END_FUNCTION

Abhilfe 1: Löschen Sie den Ausdruck auf der linken Seite der Zuweisung.
Beispiel:

PROGRAM Test
  VAR RC:INT; END_VAR
  call();    (* Dieser Aufruf ist korrekt. *)
END_PROGRAM
FUNCTION call
END_FUNCTION

Abhilfe 2: Erfassen Sie einen Datentyp bei der Deklaration der Funktion.
Beispiel:

PROGRAM Test
  VAR RC:INT; END_VAR
  RC:=call();    (* Diese Zuweisung ist korrekt, da der Datentyp des Ergebniswerts bei der Deklaration der Funktion erfasst ist. *)
END_PROGRAM
FUNCTION call:INT
END_FUNCTION

Behebung: Die fehlerhafte Zuweisung wird als Fehler gekennzeichnet.

1830

Zurück geänderte Bezeichner bei Deklarationen werden als Fehler gekennzeichnet
Szenario: Falls Sie einen Bezeichner bei einer Deklaration einer POE ändern (indem Sie den Bezeichner durch einen neuen überschreiben) und die deklarierte POE bereits verwendet wird, dann werden die Verwendungen (der nicht geänderten Bezeichner) korrekt als Fehler gekennzeichnet. Falls Sie den Bezeichner in der Deklaration wieder auf den ursprünglichen Text ändern, werden die Verwendungen weiterhin fälschlicherweise als Fehler gekennzeichnet.
Abhilfe: Verwenden Sie den Befehl Element umbenennen, um Bezeichner umzubenennen. Damit werden alle Elemente umbenannt – sowohl in der Deklaration als auch in den Verwendungen. Falls es erforderlich ist, den Bezeichner auf den ursprünglichen Text zurück zu ändern, verwenden Sie dafür ebenfalls Element umbenennen.
Behebung: Das Problem tritt nicht mehr auf.

1857

Start und Verwendung von Bausteinen nur erfolgreich, falls keine Leerzeichen im Pfad des Installationsverzeichnis vorhanden sind
Szenario: Wenn Sie logi.CAD 3 in ein Verzeichnis mit Leerzeichen installieren, erscheinen Fehlermeldungen beim Start. Es ist außerdem nicht möglich, die Bibliotheksbausteine zu verwenden.
Abhilfe: Beenden Sie logi.CAD 3 . Ändern Sie den Pfad des Installationsverzeichnis, sodass er keine Leerzeichen enthält. Starten Sie logi.CAD 3 erneut.
Behebung: Das Problem mit Leerzeichen tritt nicht mehr auf. Beachten Sie jedoch weiterhin, dass keine Sonderzeichen im Pfad sein dürfen (wie Umlaute, ä, ö, ü). Dies gilt für die Installation und Projekte. 

Release-Notes für Version 0.11.0

Neuigkeiten in Version 0.11.0

ID

Neuigkeiten

687

Im ST-Editor kann der IEC-61131-3-Systembaustein ADD als eine eingeschränkte Variante verwendet werden. Der Addierer liefert die Summe von 2 INT-Werten. Die Eingänge können mit INT-Variablen oder INT-Literalen beschaltet werden. Der Baustein bietet ebenfalls einen EN-Eingang, der mit einem Literal oder einer Variable beschaltet werden kann.

690

Im ST-Editor kann der IEC-61131-3-Systembaustein TON verwendet werden, um eine zeitgesteuerte Flanke zu erzeugen. Der Baustein bietet einen PT-Eingang, der mit einer TIME-Variable als auch -Literalen beschaltet werden kann.
Zusätzlich können im ST-Editor TIME-Variablen deklariert und im Code mit TIME-Literalen initialisiert werden.

691

Ein Programm kann auf ein Raspberry-Pi-Zielsystem unter Windows (64-Bit) geladen werden. Das Programm wird dabei automatisch gestartet.

Behobene Probleme in Version 0.11.0

ID

Behobenes Problem

1726

Mehrmals deklarierte Bezeichner in verschiedenen ST-Objekten nicht als Fehler gemeldet
Szenario: Falls Sie gleiche Bezeichner in unterschiedlichen ST-Objekten (= Dateien mit Erweiterung .iecst) verwenden, werden die gleichen Bezeichner nicht als Fehler gekennzeichnet.
Abhilfe: Vergeben Sie immer eindeutige IEC-Bezeichner als Namen, die noch nicht vergeben wurden.
Behebung: Das Problem tritt nicht mehr auf. 

1729

Absolute Pfade der IEC-61131-3-Systembausteine erschweren die Wiederverwendbarkeit von Projekten
Szenario: Wenn Sie IEC-Bausteine in einem Projekt (beim Erstellen Ihrer Programmierung in ST) verwenden, werden diese IEC-Bausteine durch absolute Pfade referenziert. Bei Wiederverwendung/Weitergabe des Projekts (z.B. auf einem anderen Arbeitsplatz) ist die korrekte Funktionsweise der Systembausteine auf dem anderen Arbeitsplatz nur gewährleistet, falls logi.CAD 3 dort im gleichen Ordner installiert ist.
Behebung: Das Problem tritt nicht mehr auf – Projekte können auf anderen Arbeitsplätzen weiterverwendet werden, auch falls logi.CAD 3 nicht im gleichen Ordner installiert ist. 

1732

Die IEC-61131-3-Systembausteine sind veränderbar.
Szenario: Ein Projekt im Projektexplorer zeigt den Ordner IEC61131-3, in dem die unterstützten IEC-Bausteine vorhanden sind. Sie können dieser Systembausteine öffnen, den Inhalt ändern und die Änderungen speichern. In Folge ist die korrekte Funktionsweise der Systembausteine nicht mehr gewährleistet.
Behebung: Das Problem tritt nicht mehr auf – Sie können die Systembausteine nicht mehr verändern.

Release-Notes für Version 0.10.1

Neuigkeiten in Version 0.10.1

ID

Neuigkeiten

688

Im ST-Editor kann der IEC-61131-3-Systembaustein AND als eine eingeschränkte Variante verwendet werden, um den Wert einer BOOL-Variablen und einer BOOL-Konstanten logisch zu verknüpfen. Der Baustein steht im Projektexplorer für alle geöffneten Projekte zur Verfügung.

689

Im ST-Editor kann der IEC-61131-3-Systembaustein NOT als eine eingeschränkte Variante verwendet werden, um den Wert einer BOOL-Variablen zu negieren. Der Baustein steht im Projektexplorer für alle geöffneten Projekte zur Verfügung.

Behobene Probleme in Version 0.10.1

ID

Behobenes Problem

1685

Mehrmals deklarierte Bezeichner erlaubt
Szenario: Mehrmals deklarierte Bezeichner (z.B. als Name einer Variable und eines Programms oder eines Funktionsbausteins) werden nicht verboten.
Abhilfe: Vergeben Sie bei den Deklarationen immer eindeutige IEC-Bezeichner als Namen, die noch nicht vergeben wurden.
Behebung: Das Problem tritt nicht mehr auf.

1695

"Programm laden" verursacht Terminierung von logi.RTS, falls geladenes Programm keine Variablen enthält
Szenario: Wenn Sie die Schaltfläche Programm laden in der Sicht SPS drücken und das Programm (bzw. darin verwendete Funktionsbausteine) enthält keine Variablen, wird das Programm zwar geladen, aber danach terminiert logi.RTS. Üblicherweise erhalten Sie in solchen Fällen diese Meldung: Zeitüberschreitung bei der Ausführung eines Zielsystem-Kommandos.
Abhilfe:

  • nur erforderlich, falls Programm laden bereits die Terminierung des logi.RTS verursacht hat: Löschen Sie die Dateien mit dem bereits geladenen Code, dies sind die Dateien RTSCode.dll und RTSCode.bak (zu finden im Unterzeichnis PLC des logi.RTS-Installationsverzeichnisses). Starten Sie den logi.RTS erneut.
  • Erstellen Sie mindestens 1 Variable in allen verwendeten Programmen und Funktionsbausteinen .
  • Nun können Sie das Programm auf den logi.RTS ohne den oben erwähnten Fehler laden.

Behebung: Das Problem tritt nicht mehr auf.

1698

"Verweise finden" im ST-Editor liefert manchmal falsche Suchergebnisse
Szenario: Wenn Sie den Befehl Verweise finden (im Kontextmenü des ST-Editors) wählen, während Sie z.B. auf der Deklaration eines Programms positioniert sind, werden alle gefundenen Verweise für das Programm angezeigt. Dabei erscheint eine Fehlermeldung, die nicht anwenderfreundlich ist, und manchmal werden falsche Suchergebnisse angezeigt.
Behebung: Das Problem tritt nicht mehr auf.

Release-Notes für Version 0.10.0

Neuigkeiten in Version 0.10.0

ID

Neuigkeiten

604

Im ST-Editor kann ein Funktionsbaustein deklariert werden. Der Funktionsbaustein kann aufgerufen werden. Innerhalb des Funktionsbaustein können lokale Variablen, Eingangsvariablen und Ausgangsvariablen deklariert werden.

742

Der Datentyp TIME wird in iecst-Objekten (für Funktionen, Funktionsbausteinen, Programmen) und in iecplc-Objekten (für die Zykluszeit) unterstützt.

1680

Der Befehl Schnellkorrektur kann verwendet werden, um bestimmte gefundene Fehler innerhalb der ST-Objekte und der SPS-Objekte zu beheben. Eine "Glühbirne" im Rand links vom Code deutet darauf hin, dass Schnellkorrekturen verfügbar sein könnten.

Behobene Probleme in Version 0.10.0

ID

Behobenes Problem

1534

Nicht möglich, zu gefundener Referenz in SPS-Objekten zu springen
Szenario: Wenn Sie den Befehl Verweise finden für ein ST-Element aufrufen und dabei Verweise in SPS-Objekten (= Objekte mit Erweiterung .iecplc) gefunden werden, ist es nicht möglich, zu diesen Verweisen aus der Sicht Suchen zu springen.
Abhilfe: Öffnen Sie das SPS-Objekt aus dem Projektexplorer.
Behebung: Das Problem tritt nicht mehr auf.

1644

Keine anwenderfreundliche Meldung bei Compile-Fehler für "Programm laden"
Szenario: Wenn Sie die Schaltfläche Programm laden in der Sicht SPS drücken, aber der dafür erforderliche Compile-Prozess nicht erfolgreich war, erscheint die Meldung Fehler bei Ausführung eines Zielsystem-Kommandos.
Behebung: Die Meldung Das Programm für die SPS kann nicht erstellt werden. Prüfen Sie das Fehlerprotokoll für weitere Informationen. wird angezeigt.

1657

Inhaltshilfe bietet Elemente, die im aktuellen ST-Kontext nicht gültig sind
Szenario: Falls Sie im ST-Editor den Befehl Inhaltshilfe wählen, erhalten Sie eine Liste mit allen passenden Elementen. Die Liste bietet jedoch u.A. Elemente, die im aktuellen ST-Kontext nicht gültig sind. Falls Sie solch ein Element aus der Liste selektieren, wird der ungültige Ausdruck als fehlerhaft markiert und Sie erhalten die Meldung Konnte die Referenz auf Element nicht auflösen. Beispiel: Innerhalb einer POE bietet die Inhaltshilfe die lokalen Variablen von allen POE, die im ST-Objekt enthalten sind. Innerhalb des Programms PT1 können Sie die lokalen Variablen des Programms PT2 wählen, obwohl auf diese nicht zugegriffen werden kann.
Abhilfe: Korrigieren Sie den ungültigen Ausdruck in der ST-Sytnax – entweder durch Selektion eines anderen Elements aus der Inhaltshilfe-Liste oder durch Tastatur-Eingabe dieses Elements.
Behebung: Das Problem tritt für das geschilderte Beispiel nicht mehr auf.

Release-Notes für Version 0.9.0

Neuigkeiten in Version 0.9.0

ID

Neuigkeiten

607

logi.CAD 3 prüft, ob eine typsichere Zuweisung auf Variablen möglich ist. Fehlerhafte Zuweisungen werden gemeldet, z.B. Zuweisung eines booleschen Literals auf eine Variable vom Datentyp INT. Nicht explizit typisierte Zuweisungen (z.B. var1 := 1;) werden aus dem Kontext heraus aufgelöst (z.B. als BOOL-Variable).
Folgende Datentypen werden für diese Prüfung/Auflösung unterstützt: BOOL, INT und TIME

1656Die SPS-Objekte (Objekte mit SPS-Informationen) haben nun die Datei-Erweiterung .iecplc im Projektexplorer (bisher hatten sie die Datei-Erweiterung .iecsps).

Behobene Probleme in Version 0.9.0

ID

Behobenes Problem

1057

Keine Syntaxhervorhebung von Schlüsselwörtern bei manueller Eingabe, die einen Deklarationsblock schließen (z.B. END_VAR)
Szenario: Wenn Sie Schlüsselwörter für Deklarationsblöcke im ST-Editor über die Tastatur eingeben (z.B. VAR und END_VAR), wird das abschließende Schlüsselwort (hier END_VAR) nicht farblich und fett hervorgehoben (= keine Syntaxhervorhebung).
Abhilfe: Erfassen Sie das abschließende Schlüsselwort mit Hilfe des Befehls Inhaltshilfe (z.B. im Kontextmenü) oder fügen Sie eine zusätzliche neue Zeile vor dem abschließenden Schlüsselwort ein.
Behebung: Das Problem tritt nicht mehr auf.

1407

"Programm laden" funktioniert nur, falls keine Leerzeichen im Namen des Installationsverzeichnis vorhanden
Szenario: Wenn Sie die Schaltfläche Programm laden in der Sicht SPS drücken, wird das Programm nur geladen, falls logi.CAD 3 in ein Verzeichnis ohne Leerzeichen installiert wurde. Falls der Name des Installationsverzeichnisses Leerzeichen enthält, wird die Aktion zwar begonnen, aber nicht abgeschlossen. Es ist nicht möglich, die Aktion zu stoppen und/oder das Programm zu laden.
Abhilfe: Beenden Sie logi.CAD 3 mit Hilfe von Betriebssystem-Funktionalitäten (z.B. Task-Manager). Ändern Sie den Namen des Installationsverzeichnis, sodass er keine Leerzeichen enthält. Starten Sie logi.CAD 3 und Programm laden erneut.

Behebung: Das Problem mit Leerzeichen tritt nicht mehr auf. Beachten Sie jedoch weiterhin, dass keine Sonderzeichen im Pfad sein dürfen (wie Umlaute, ä, ö, ü). Dies gilt für die Installation und Projekte.

1556

Fehler bei Doppelklicken auf Schaltfläche "Programm laden"
Szenario: Wenn Sie auf die Schaltfläche Programm laden in der Sicht SPS doppelklicken, wird ein Fehler ausgegeben.
Abhilfe: Klicken Sie nur einmal auf die Schaltfläche, um das Programm zu laden.
Behebung: Der Fehler tritt nicht mehr auf.

Release-Notes für Version 0.8.0

Neuigkeiten in Version 0.8.0

ID

Neuigkeiten

860

Für das SPS-Objekt local.iecsps unter Windows (64-Bit) werden folgende Status-Informationen im Register "SPS" angezeigt:

  • Status des SPS: Online? Offline?
  • weitere Informationen zur SPS, z.B. Adresse und Port
  • Image geladen: durch wen? wann? eindeutige Identifikation?

Behobene Probleme in Version 0.8.0

ID

Behobenes Problem

1038

"Programm laden" erstellt Code nur, falls mind. ein Editor geöffnet
Szenario: Wenn Sie die Schaltfläche Programm laden in der Sicht SPS drücken, wird dabei nur Code erstellt, falls mind. ein ST-Editor bzw. ein Editor für SPS-Objekt geöffnet ist. Ist kein Editor geöffnet, wird kein Code erstellt.
Abhilfe: Öffnen Sie zumindest einen Editor. Erst danach drücken Sie auf Programm laden.
Behebung: Das Problem tritt nicht mehr auf.

1388

"Programm laden" auch verfügbar, wenn Aktion nicht möglich
Szenario: Die Schaltfläche Programm laden in der Sicht SPS ist verfügbar, obwohl die Aktion nicht möglich ist. Beispiele: kein Projekt vorhanden/geöffnet, keine Plattform im SPS-Objekt eingetragen
Behebung: Das Problem tritt nicht mehr auf. Das Laden des Programms ist nicht möglich.

1391

Keine Meldung bei Verbindungsfehler für "Programm laden
Szenario: Wenn Sie die Schaltfläche Programm laden in der Sicht SPS drücken, aber die Verbindung zur SPS nicht hergestellt werden kann, erscheint keine Rückmeldung.
Behebung: Das Problem tritt nicht mehr auf. Es erscheint eine Rückmeldung.

1404

Keine Ausführung von aufgerufenen Funktionen
Szenario: Wenn eine Funktion innerhalb eines Programms aufgerufen wird, wird diese Funktion nicht ausgeführt.
Behebung: Das Problem tritt nicht mehr auf.

Release-Notes für Version 0.7.0

Neuigkeiten in Version 0.7.0

ID

Neuigkeiten

849

Die Attribute für das SPS-Objekt local.iecsps, die für das Laden des Programms erforderlich sind, können spezifiziert werden. Der erzeugte Binär-Code kann auf die lokale SPS unter Windows (64-Bit) geladen werden, danach wird das Programm auf der lokalen SPS automatisch gestartet.

Behobene Probleme in Version 0.7.0

ID

Behobenes Problem

835

"Elemente umbenennen" verursacht fehlerhaften Ausdruck, wenn beide Objekte mit umbenanntem Element gleichzeitig geöffnet
Szenario: Wenn Sie mit Hilfe von Element umbenennen ein zugeordnetes Programm in einem SPS-Objekt umbenennen und das ST-Objekt, in dem das Programm deklariert ist, ist ebenfalls geöffnet, wird das Programm korrekt im SPS-Objekt und im ST-Objekt umbenannt. Das umbenannte Programm wird jedoch irrtümlich als fehlerhafter Ausdruck markiert. Diese Markierung erfolgt auch in anderer Richtung irrtümlich, d.h., falls Sie ein Programm im ST-Objekt umbenennen, das bereits in einem SPS-Objekt als Programm zugeordnet ist, und falls beide Objekte geöffnet sind.
Abhilfe: Speichern Sie das Objekt, in dem Sie Element umbenennen aufgerufen haben. Danach schließen Sie dieses Objekt und öffnen Sie es erneut. Dadurch wird das umbenannte Programm nicht mehr länger als fehlerhafter Ausdruck markiert.
Behebung: Das Problem tritt nicht mehr auf.

1046

"Programm laden" trotz Fehler im ST-Code möglich
Szenario: Im ST-Code, welcher für die Programmgenerierung einer Ressource verwendet wird, sind Fehler enthalten. Diese Fehler werden in der Problem-Ansicht angezeigt. Das Programm kann dennoch auf das Zielsystem geladen werden.
Behebung: Wenn im ST-Code Fehler enthalten sind, kann das Programm nicht mehr auf ein Zielsystem geladen werden.

Release-Notes für Version 0.6.0

Neuigkeiten in Version 0.6.0

ID

Neuigkeit

838

Ein Code-Image (DLL), das mit logi.RTS kompatibel ist, kann für ein vorgegebenes Programm unter Windows (64-Bit) erzeugt werden. Die Erzeugung wird durch Befehl Programm laden ausgelöst. Die Ziel-Plattform und die Zykluszeit sind in neuen Projekten automatisch vorgegeben.
Hier das Programm (als "Einzeiler"):
PROGRAM Template VAR int_var : INT; END_VAR int_var := 815; END_PROGRAM

Behobene Probleme in Version 0.6.0

ID

Behobenes Problem

682

Kein Meldungstext, wenn Projekt nicht erstellt werden kann
Szenario: Falls ein Projekt in einem Ordner erstellt wird, aber für diesen Ordner keine Zugriffsrechte vorhanden sind, erscheint ein Fehler, aber ohne Meldungstext.
Behebung: Der Fehler wird mit einem anwenderfreundlichen Meldungstext ausgegeben.

900

Beim Schließen von logi.CAD 3 erscheinen unter Linux Fehlermeldungen, deren Bedeutung unklar ist. logi.CAD 3 wird aber trotzdem geschlossen.
Das Problem wird nicht von logi.CAD 3 verursacht, sondern von der grafischen Benutzeroberfläche des Linux-Betriebssystems.

Release-Notes für Version 0.5.0

Neuigkeiten in Version 0.5.0

ID

Neuigkeit

595

Im SPS-Objekt local.iecsps kann ein im Projekt existierendes Programm zugeordnet werden. In neuen Projekten ist aufgrund der Vorlage das bereits vorhandene Programm "Template" zugeordnet.

Behobene Probleme in Version 0.5.0

ID

Behobenes Problem

675

Kein Titel für Dialog mit Lizenzvereinbarungen
Behebung: Der Dialog mit den Lizenzvereinbarungen hat einen Titel.

Release-Notes für Version 0.4.0

Neuigkeiten in Version 0.4.0

ID

Neuigkeit

452

Im ST-Editor kann eine Funktion deklariert werden. Die Funktion kann innerhalb des Programms aufgerufen werden. Ein Ergebniswert kann innerhalb der Funktion zugewiesen werden. Innerhalb der Funktion kann außerdem eine lokale Variable deklariert werden, dieser können eine Konstante von den unterstützten Datentyp zugewiesen werden.

549

Neue Projekte werden aufgrund einer Vorlage erstellt. Sie enthalten die SPS-Objekte local.iecsps und remote.iecsps mit Standardwerten.

582

Verbesserter Startbildschirm und Lizenzbedingungen

Behobene Probleme in Version 0.4.0

ID

Behobenes Problem

532

Assistent zum Erstellen von neuen Projekten zeigt falschen Projektnamen
Behebung: Der Projektname wurde auf logi.CAD 3 Projekt geändert.

548

Projekte können nicht an beliebigen Positionen des Dateisystems erstellt werden, sondern nur an der vorgegebenen Standardposition
Behebung: Projekte können an anderen Positionen erstellt werden (sofern die Berechtigungen dafür vorhanden sind).

563

Filter-Möglichkeit für Projektexplorer bietet Eintrag *.class - Ressourcen. Der Eintrag bewirkt nichts.
Behebung: Der Eintrag wurde entfernt.

564

Der Projektexplorer zeigt Projekte nicht automatisch an, direkt nachdem logi.CAD 3 gestartet wurde.
Behebung: Projekte werden im Projektexplorer sofort nach dem Starten angezeigt.

606

Groß-/Kleinschreibung wird im ST-Code für Schlüsselwörter nicht korrekt berücksichtigt.
Behebung: Schlüsselwörter können im ST-Code sowohl mit Groß- als auch mit Kleinschreibung erfasst werden (= "Case Insensitivity" wird unterstützt).

Release-Notes für Version 0.2.0

Neuigkeiten in Version 0.2.0

ID

Neuigkeit

451

Bei Zuweisungen auf lokale Variablen (auf der rechten Seite des Zuweisungsoperators ":=") können Integer-Literale und boolesche Literale verwendet werden.

470

Die Benutzerdokumentation von logi.CAD 3 kann in der jeweiligen Sprache als Hilfe aus logi.CAD 3 heraus geöffnet werden.

494

Ein Projekt kann erstellt werden und wird im Projektexplorer angezeigt. Ein bestehendes, aber nicht mehr angezeigtes Projekt kann geöffnet bzw. importiert werden.

495

Ein im Projektexplorer angezeigtes Projekt kann geschlossen bzw. gelöscht werden, sodass es nicht mehr im Projektexplorer sichtbar ist, aber noch im Betriebssystem verfügbar ist.

Behobene Probleme in Version 0.2.0

ID

Behobenes Problem

489

Keine anwenderfreundliche Meldung für nicht erfolgreiche aufgelöste Referenz im ST-Editor
Behebung: Meldung Konnte die Referenz auf 'Name' nicht auflösen. wird ausgegeben.

Release-Notes für Version 0.1.0

Neuigkeiten in Version 0.1.0 

ID

Neuigkeit

430

Der ST-Editor bietet einen minimalen Sprachumfang (PROGRAM ... END_PROGRAM, Kommentare) mit Inhaltshilfe, Syntaxhervorhebung, Code-Faltung und Kennzeichnung von Syntax-Fehler.

443

Lokale Variablen können deklariert werden. Unterstützte Datentypen sind: BOOL, SINT, INT, DINT, USINT, UINT, UDINT, REAL, LREAL, STRING, CHAR, BYTE, WORD, DWORD. Anwenderfreundliche Meldungen bezeichnen dabei die Syntaxfehler.

446

Lokale Variablen können einander zugewiesen werden, sofern diese bereits deklariert sind. Anwenderfreundliche Meldungen bezeichnen dabei die Syntaxfehler.

450

Der ST-Editor bietet eine Inhaltshilfe ("Content Assist") bei der Zuweisung von lokalen Variablen, sofern diese lokalen Variablen bereits deklariert sind.

468

logi.CAD 3 kann auf allen unterstützten Betriebssystemen installiert werden.

469

logi.CAD 3 kann auf den unterstützten Betriebssystemen in allen unterstützten Sprachen gestartet und beendet werden.